Domain connect to cloudflare but mobil App can't connect to website anymore

Hello

I just started use Cloudflare
I set the dns for my domain and it works but i have now problem with my mobil App that connect also to my site before without any problem
but after i transfer my domain to Cloudflare the App’s can not connect anymore it only shows the startup screen and spinning
i have try several option in the panel settings but result still the same
can anyone help me and point me to how i need to set any option on the Cloudflare panel ?
thanks

Any error messages?

Which port does the app use?

there is no any error messages
it starts up and you see the first screen and then he trys to connet but thats all the spin icon never ends !

when i test my app in android stuio it connects to the site without any problem but when i convert it to apk and load it to my phone it never connects !

and as i can see the App use port up to 49000 to 53000

Cloudflare :orange: hostnames only proxy HTTP/S traffic over a set group of ports:
https://support.Cloudflare.com/hc/en-us/articles/200169156-Which-ports-will-Cloudflare-work-with-

the ports i see is when i use android studio but normally it have a setting to connect over the http/s: in the settings

and in the cloudfare the http option are not active on my panel

the port i see are maybe wrong because i just did a cmd netsate to see the outgoing ports from the android studio
but when i look to the program in i can’t found any port that was setting for the App’s just a url to connect to my site !

the test domain is www.sanabana.net

i have talk with the developers and he says that he was used
HTTP/HTTPS for API, so 80/443

The sanabana website works, but if you try to use www, it will redirect to non-www (just sanabana dot net).

If the mobile app insists on www, that may be the problem. If the app is configured for non-www (sanabana.net), then I suggest you check back with the developers, or look through your server logs for connections from that app.

sdayman thanks for the replay

i have convert the App both with www and without www
but it still not connecting
it seems like the web site get the msg connection from the App but the App dont get the responce from the API on the website
looks like firewall don’t let get out any messages from the website to connect to the App

and also i can’t set on / off the http option on my panel ! because it is not active

What’s the SSL setting in the Crypto section of your Cloudflare Dashboard? It should be Full (Strict).

yes it is set to Full (Strict).

but the interesting one is when i run my App with android studio it connects to the site without any problem
but when i run the Apk on the mobil phone it connects not
it seems that Cloudflare blocks somethinks on the IPv4 or 6 i dunno

it starts working now

i disable the settings

Always Use HTTPS

Opportunistic Encryption

Automatic HTTPS Rewrites

disable TLS 1.3

and seems to working

That’s worrying. I don’t think the TLS version would have an affect (it might), but turning the other stuff off makes it sound like the app only works with HTTP, an unencrypted connection.

hmm but the APPs url are assign with https:// and this was work with my site ok
but with Cloudflare not

At this point, you’re really going to have to get a developer to dig through your system to see what’s going on. Your site works properly. The app does not.

This topic was automatically closed after 14 days. New replies are no longer allowed.