Domain CNAME redirected to another IP than mine

CNAME is pointing back to CloudFlare servers, instead of my dynamic DNS. Image bellow.

I can’t use my site anymore under the old name.

It says the warning message as in the image above, and the redirected CNAME is pointing to CloudFlare IP 104.21.29.208, instead of my dynamic DNS s(…)n.g.r. (which is hosted somewhere else).

This happened while I tried to move from the old dynamic dns m(…)n.g.r to the new dynamic dns s(…)n.g.r.
CloudFlare suggests there’s already a record with my domain that’s using the same name, which is practically impossible, unless CloudFlare maliciously retains it or it is being hooked somewhere in the service.

There isn’t a possibility for having any record with the same name, due to the fact that NSs has been configured correctly as per CloudFlare instructed (image bellow).

image

Is there anything I can do?

If that’s your principal domain, there’s the default SOA record on the domain which can’t be removed. CNAMEs generally can’t be applied at the root so CF will allow you to make one via flattening, even though it’s against dns spec to actually have a CNAME returned there.

As for why it’s returning a Cloudflare IP, that’s because the domain is proxied. If you change to DNS only, you’ll lose ddos protection but the real IP will be returned. If you wish to stay proxied, see:

2 Likes

If the real IP can also by a dyn DNS, I would gladly prefer to DDOS protect myself.

Still wondering why is there a message on CloudFlare DNS as “steps required (…) for my www, root domain to resolve” since it doesn’t resolve anyway, even with CNAME flattening.

No matter what CNAME record I set (to static IP or dynamic DNS), it doesn’t resolve. It doesn’t feel like anything is helping from any of CF docs, either.
I literally don’t know what to do. Tried everything.

Then set the record to :grey: and you’ll be fine.

It simply tells you that you don’t have any record for the root, for www and you don’t have any MX records.

I completely understand what it says, I mentioned thereafter that even if it tells me to set a record, it still won’t resolve anyway. So why should it tell me that if it doesn’t work? Doesn’t make any sense.

Previously I had no problem with it, I literally can’t understand why would it not work if I just changed the target, not the type, name or even the proxy status of the record.

What is mean is, through the steps of the problem:
-> CF Service tells me to set a record for root domain: A, AAAA, CNAME.
-> I set a CNAME record for root domain to a static IP.
-> CF Service tells me there’s already a record for the CNAME, so it resorts to flattening.

I mean I don’t want to be rude or bad mouthed, but I think this doesn’t make sense. With all honesty and good intention.

On the root record (example.com), per DNS spec, you can’t have a CNAME. If it’s set as a CNAME, which Cloudflare allows, the response from DNS would become either Cloudflare IPs (if one of the records for that hostname is :orange:) or the IP following all the CNAME chain (if it’s :grey:).

Without having a screenshot unfortunately it’s hard… redact the names and IPs, if you want.

1 Like

You answered my main concern. Thank you kindly :slight_smile:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.