Domain behind cloudflare

Hello all,

We have a cloud management site allows us to create and destroy VM’s , one of the features you can open the VM console on browser,

however that link keeps giving:
The page isn’t redirecting properly
An error occurred during a connection to
This problem can sometimes be caused by disabling or refusing to accept cookies.

I look into the product, seems like it is only using port 443 for communication no - custom ports are assigned. the port forwarding is happening internally on the application level, when we shutoff the orange cloud - it works fine.

anyone has that same issue ?

There are tons of ways to do this, but many solutions do use ports other than 443, so you might want to double check as this is one of the most likely things to change when you turn off proxying (:grey:).

It could be useful to pull up browser tools and see exactly what redirect/request is failing.

Yes when we turn off (Gray Cloud) only DNS it works fine, this is how I knew CF is blocking something.

It does not use ports other than 443, the application internally goes to Esxi host and grabs the console.

I tried even putting the Page Rule, but nothing really. I have attached the console debug, but I do not see any port forwarding there

In the debug I see sometihng like this.

Note the ‘Location’ header? It is trying to redirect from HTTPS to HTTP.

Do you happen to be using Flexible encryption? If so, turn it off (Full is a minimum) and try again?

1 Like

In the debug I see sometihng like this.

you are correct,

however - I just created a PageRule, to allow anything on /server/* to “Automatic HTTPS Rewrites: Off”. But that did not work, even tried SSL = off.

and seems to work when I turn off “Always Use HTTPS”. in edge-certificate.

is there a better way to do this ? or Am I using PageRules wirth the wrong options

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.