Domain as an alias

Hi there!

We use the domain “xxxxxxx.ru” as an alias on the target server.

Cloudflare contains two A-records on the target server’s IP. But when we go to this URL with a browser, Cloudflare displays an error 520. Is it nessesary to configure something additional if the domain on the target server is used as an alias?

Possibly few issues - SSL or Cloudflare not allowed to connect (Firewall maybe).

Regarding Cloudflare 520 error, may I suggest you to try looking into below articles to troubleshoot the issue:

Before moving to Cloudflare, was your Website working over HTTPS connection?
If so, did you had an valid SSL certificate installed at your origin host / server which covers both your naked (root) domain any any other needed sub-domain like www, mail, etc.?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

Regarding available SSL options at Cloudflare dashboard, check here:

If any other issues appear, follow the needed steps for troubleshooting from article below:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

Furthermore, do not skip below step and kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

Ports list compatible and supported when using :orange: cloud (proxy mode) on Cloudflare can be found here: