Domain almadeaventura.cl redirects to IP address instead of www.almadeaventura.cl

Hi all, thanks for your help

I have a domain almadeaventura.cl with Cloudflare DNS, and the site is hosted on Google Cloud with OpenLiteSpeed. When people enter www.almadeaventura.cl, it redirects to the IP address. In the browser, it should stay as www.almadeaventura.cl.

HTTPS also doesn’t work, even though it is set up on the server. What configurations do I need to check to make sure it is working correctly?

Thanks a lot

issue video

https://www.loom.com/share/ab170e4b6f6147d4a0cb2a5188ed8601?sid=12f1a960-934e-4cb8-bdd2-f12a3734f352

Screenshot 2023-11-06 at 22.15.19

Hi Gustavo,

This is not a DNS issue. Unless you explicitly set up a Cloudflare Page Rule (or something similar) to redirect to the IP address, the redirect is most likely coming from the server behind Cloudflare, not from Cloudflare.

If you set your DNS record on the “www” label to “DNS only” (not proxied), and you still get redirected, the redirect is for sure done by the web server your “www” record is pointing to.

(HTTPS likely doesn’t work because the certificate only covers your domain, not that raw IP address, so it’s probably a consequence of the same issue.)

thanks for your help…

i send you a video of my config

i think no rules… and DNS ONLY on CNAME option (both options same result)

https://www.loom.com/share/291a02f163d64a0fb8c93ac5cbe4b414?sid=607b0c60-0ea3-4187-a299-c8e7a9a178d1

The root of your problem is that you installed your WordPress site with the IP address, rather than the domain name. The address used to install WordPress (IP address in your case) is fixed in the database and used to general ALL WordPress URLs.

That’s why, not just your homepage, but all your inner pages and posts show the IP address in their permalinks instead of your domain name. Same deal with the URLs of all attachments (uploaded files).

You need to configure your WordPress site to use your domain name rather than the IP address. Follow the official WordPress documentation below to change your WordPress site address.

And if you need further help with this, please head over to the official WordPress support forum, as, clearly, this is not a Cloudflare issue.

Good luck!

2 Likes

thanks to all brothers…

i check the rules (no rules)
i set www to “DNS only” (is better to put again in proxy?)
i change the site root to https://www.almadeaventura.cl

and all is ok

www.almadeaventura.cl
1 Like

If you want to use Cloudflare’s performance and security features, then, yes, you do need to set the name to :orange: proxied

perfect… i think is better :point_up:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.