Domain Alias Forwarding Rule Not Working for Me

I cannot get my subdomains to redirect accordingly.

I setup a subdomain cname pointing to (I also tried using an A-Record, but got the same result). I made sure the Orange Cloud was active.

I then added a Forwarding Rule and I can’t get it to work.

My TLD is forwarding just fine using the same setup (A-Record for TLD, and CNAME for www). It’s only when it comes to forwarding from a subdomain to a different doman that it seems not to work.

I’ve seen this post several times. I’ve tried testing things with an A-Record and then a CNAME record. I tried it with the orange cloud active, and not-active. I waited a while just in case there was an extraneous propogation issue (though an IP resolved when I pinged the URL)… I’m at a loss.

Any helps would be appreciated. I moved to Cloudflare, and purchased extra Redirects, and I cannot seem to get them working.


If that weren’t impossible, I’d say I’m impressed. A CNAME resolves an alias in the NAME field to a canonical name in the RDATA field. This means that it must contain a name, not an IP address.

Forwarding rules configured in your Cloudflare account are executed by the Cloudflare proxy. Your site’s traffic will be directed to the Cloudflare proxy only when the name is set to :orange:. If you turn that off and set it to :grey: DNS Only the traffic will not be sent to the Cloudflare proxy which means there is no chance of your redirect rules being applied.

How many subdomains are you attempting to redirect? You get 15 Bulk Redirect Rules and 5 Bulk Redirect Lists in both the Free and the Pro plans.

This might be a good time to take a step back and share a broader view of what you want to accomplish. If redirects are the best fit, looking at the method and syntax of your redirects will be the next step.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.