Domain AAAA record only doesn't work

Hello, I have a problem with my domain and IPv6, my VPS provider only give a IPv6 so I need to use it to get a working website !

Sadly when I ping the domain nothing is resolved, proxied or no it doesn’t work…

I want to let you know my ISP give a IPv6 too with IPv4

Any solution around or do I need to find another anti-ddos provider ?

Regards.

What’s the domain and what’s the hostname?

Generally, Why does a DNS lookup on my domain not return the IP address I configured?

Well it’s not the matter (the link you returned me)

The domain:

est-un-sans-domaine-fixe.xyz

Well, your original statement is not correct, as the AAAA entry is in place.

nslookup est-un-sans-domaine-fixe.xyz quentin.ns.cloudflare.com
Server:  quentin.ns.cloudflare.com
Address:  162.159.44.7

Name:    est-un-sans-domaine-fixe.xyz
Addresses:  2606:4700:3037::ac43:84ad
          2606:4700:3034::6815:4fe
          104.21.4.254
          172.67.132.173

The reason why it does not resolve is because you have an incorrect DNSSEC setup and need to fix this at your registrar. You need to set the correct values as provided by Cloudflare. Use the search for more details as this has been discussed quite a few times.

1 Like

Ah, the AAAA record is there yeah if you watch my first screenshot, but it doesn’t resolve or anything, I’m using OVH as registrar and I disabled it…

Sure it doesn’t resolve, for mentioned reason.

$ dig +short @z.nic.xyz est-un-sans-domaine-fixe.xyz DS

30400 8 2 60726371C4ED1CD90FA59D52DF3397DC130013D4338B59CC6B5069EB 451568F9

Contact your registrar if you need further advice, respectively use the search as mentioned.

Thanks I just started a sent a ticket on OVH support and will give updates about it

Okay I solved it thanks !

Did enable DNSSEC on Cloudflare to get the DS record to add on the registrar then BOOM it worked :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.