Does not equal or does not contain doesn't seem to work

Whenever I try a does not equal or does not contain in the firewall it doesn’t do as I think it should.

Case one:

Saying if not equal to HTTP 2 then it should block. Now my browser fetches my website in HTTP 2 and yet I’m blocked. It’s equal to HTTP 2 so I should get through, correct?

Case two:

I’m trying to set it up so if my website cookie isn’t present you get blocked. Again, tried a not contain or not equal to my cookie and you still get blocked even though the cookie is present. This cookie I chose was the name of, Got_milk_k and has no value. So in the firewall I tried if not contain Got_milk_k then block or if not equal Got_milk_k then block. None work. I also tried If not contain Got_milk_k= then block and if not equals Got_milk_k= then block. Still no joy. See screenshot here.

Maybe I don’t understand the rules?

1

Can you screenshot the firewall rule you’ve created? Also, provide a proof of your browser that is actually connecting to your website via HTTP/2 (e.g. F12 Developer Tools - Network tab)

This post was flagged by the community and is temporarily hidden.

So it does in fact work. Not sure what I did before.

Now how do I solve the cookie issue?