Does cloudflare cache only images or the webpages themselves?

do I have to add another setting to the first rule regarding the cashe level – standard?
should I add the browser cashe TTL ? if yes, what is the standard time to be set
?

That is the rule you already posted earlier. What about the second (respectively first) one I kept mentioning?

now I added level cashe level – standard as a first rule page
and added another security one for admin dashboard as this screenshot am I right?

None of that is PNG related though, and with the current order the second rule will never execute and you will always apply the standard caching level.

Again, please follow my original explanation, assuming you dont want to cache anything except for PNG files.

sorry for bothering you I really do appreciate your help!
so now
-I removed the admin rule page
-added standard cashe level as first page but I can’t add bypass cash level in order to prevent anything else according to your first explaination ?

All right, from the start.

What exactly do you want to cache and what exactly not. You originally wrote you only want to cache .png files and nothing else. Is that accurate?

yes that’s accurate

In this case I can only refer to the exact things I wrote earlier. Your current rules do not reflect that.

alright I removed the protocol the proble that I can’t add two cashe level setting (standard,bypass) for the same url (wikipng.com)

For the same URL? You will need two rules and there it should be possible, shouldnt it? Can you post again a screenshot of your rule list?

No it shouldn’t even when I’m adding another rule
Here is a screenshot when adding bypass cashe level to my main domain Wikipng.com/*

All right, then post a screenshot of your existing rules and another screenshot of the rule you are trying to set up and which throws that error message.

1 Like

Here is a screenshot of the only rule page I have successfully added


And this is the screenshot I already uploaded regarding the error I get when adding another page rule

Both are the same url
Wikipng.com/*

That is the reason why you get that error message.

You cant set two rules for the same path and you wouldnt want either, as one of them should apply to PNG files, right?

All right, to shorten that now. As I mentioned initially, you need exactly two rules

  1. *wikipng.com/*.png -> Enable caching
  2. *wikipng.com/* -> Bypass caching

I think I should start charging :wink:

2 Likes

Haha you really must do! I completely appreciate your help thank you.
I did what you told me but seems like there is still something wrong, my website is still slow until I added Cloudflare that’s something I can feel, the dynamic elements are stretching in and out which upnormal and also cashe isn’t working fine according to this test
https://www.webpagetest.org/result/190614_D8_3e7b020c24bb89196a7cc3cbfe6ed352/

I feel like the page rules doesn’t affect anything even when cleaning browser cashing and flushing DNS, It might be because I skipped the protocol ?

Well, the rules I posted did not skip the protocol. Post a screenshot of the rule list you currently have.

Your domain does not seem to be configured for Cloudflare in the first place. It does not proxy through Cloudflare and not even the nameservers are set. Before anything can work (let alone page rules) you will need to set up your domain.

This topic was automatically closed after 30 days. New replies are no longer allowed.