Does cloudflare affect Google's ability to fetch my website?

cache

#1

One of our Wordpress plugins was recently updated and causing it’s settings to reset for some reason. This then allowed private information to be displayed in search results. Since that time I’ve removed the information, but the search results still display the information.

I’ve purged everything, made multiple ‘fetch as google’ requests, added robots.txt files, and updated and reset the plugin’s settings, but nothing appears to be working. Even with the private information removed from the directory’s entry, search results display the private information.


#2

No, Cloudflare does not interfere with Google’s crawler. But there are settings you would have to deliberately set that can prevent Google from crawling your site.


#3

What settings are those? Wondering if I accidentally may have done that or something.


#4

By your description, you may have turned on a Page Rule to “Cache Everything.” That’s not really “interference,” but there are firewall rules you could add to block Google.


#5

I had purged everything but my understanding was that was temporary. I did change the cache setting to 1 month, but have since switched it back to 30 minutes.


#6

Cache Everything is a bad idea on pages that display private information. Here’s a better approach for caching WordPress:


#7

I’m not sure what you are saying or how this would fix my issue. My understanding was the purge everything feature was just a one time wipe so the website could reload a more updated version vs pulling old versions from satellite servers.


#8

It doesn’t look like this would be a Cloudflare issue. Had you by mistake blocked Googlebot either with a firewall rule or a page rule, you’d had received a warning about it in about a couple days at your Google Search Console dashboard. Also, do not use robots.txt to block the resource you want updated.

Fetching as Google will not work if the content has not changed substantially (besides the undesired adding of private information). You’d need to ask Google to actually remove the affected pages from their cache. Go to the old GSC > Google Index > Remove URLs and click the “Teporarily hide” button. Follow the instructions to remove from cache only.

If that doesn’t solve your problem, I believe your issue would be best addressed at the appropriate Google forum.


closed #9

This topic was automatically closed after 14 days. New replies are no longer allowed.