Docusaurus - Failed Deploy

:vulcan_salute: Hello!

I’m try to deploy a Docusaurus (v3) via the Cloudflare dashboard, but everytime get error:

2023-12-08T20:11:40.54265Z	Cloning repository...
2023-12-08T20:11:42.698135Z	warning: redirecting to https://gitlab.com/myaccount/docusaurus.git/
2023-12-08T20:11:42.698792Z	From https://gitlab.com/myaccount/docusaurus
2023-12-08T20:11:42.698972Z	 * branch            d3752d227b67bf0eeccc89e9c05f033c9e2c56c9 -> FETCH_HEAD
2023-12-08T20:11:42.699109Z	
2023-12-08T20:11:43.814522Z	HEAD is now at d3752d2 feat(core): enable port configuration via environment variable (#9610)
2023-12-08T20:11:43.815506Z	
2023-12-08T20:11:43.948399Z	
2023-12-08T20:11:43.985596Z	Success: Finished cloning repository files
2023-12-08T20:11:44.792495Z	Detected the following tools from environment: [email protected], [email protected]
2023-12-08T20:11:44.793414Z	Installing project dependencies: yarn
2023-12-08T20:11:45.584413Z	➀ YN0070: Migrating from Yarn 1; automatically enabling the compatibility node-modules linker πŸ‘
2023-12-08T20:11:45.585261Z	
2023-12-08T20:11:45.856219Z	➀ YN0000: β”Œ Resolution step
2023-12-08T20:11:47.194814Z	➀ YN0061: β”‚ workbox-window@npm:6.6.1 is deprecated: this package has been deprecated
2023-12-08T20:11:47.289491Z	➀ YN0061: β”‚ workbox-precaching@npm:6.6.1 is deprecated: this package has been deprecated
2023-12-08T20:11:47.347395Z	➀ YN0061: β”‚ workbox-build@npm:6.6.1 is deprecated: this package has been deprecated
2023-12-08T20:11:47.516159Z	➀ YN0032: β”‚ sharp@npm:0.32.6: Implicit dependencies on node-gyp are discouraged
2023-12-08T20:11:47.753253Z	➀ YN0061: β”‚ workbox-routing@npm:6.6.1 is deprecated: this package has been deprecated
2023-12-08T20:11:47.77674Z	➀ YN0061: β”‚ workbox-strategies@npm:6.6.1 is deprecated: this package has been deprecated
2023-12-08T20:11:49.019668Z	➀ YN0061: β”‚ acorn-dynamic-import@npm:4.0.0 is deprecated: This is probably built in to whatever tool you're using. If you still need it... idk
2023-12-08T20:11:49.695731Z	➀ YN0061: β”‚ workbox-core@npm:6.6.1 is deprecated: this package has been deprecated
2023-12-08T20:11:49.836456Z	➀ YN0061: β”‚ rollup-plugin-terser@npm:7.0.2 is deprecated: This package has been deprecated and is no longer maintained. Please use @rollup/plugin-terser
2023-12-08T20:11:49.946369Z	➀ YN0061: β”‚ workbox-recipes@npm:6.6.1 is deprecated: this package has been deprecated
2023-12-08T20:11:50.03288Z	➀ YN0061: β”‚ workbox-broadcast-update@npm:6.6.1 is deprecated: this package has been deprecated
2023-12-08T20:11:50.066228Z	➀ YN0061: β”‚ workbox-expiration@npm:6.6.1 is deprecated: this package has been deprecated
2023-12-08T20:11:50.090147Z	➀ YN0061: β”‚ workbox-navigation-preload@npm:6.6.1 is deprecated: this package has been deprecated
2023-12-08T20:11:50.183134Z	➀ YN0061: β”‚ workbox-streams@npm:6.6.1 is deprecated: this package has been deprecated
2023-12-08T20:11:50.224848Z	➀ YN0061: β”‚ workbox-google-analytics@npm:6.6.1 is deprecated: this package has been deprecated
2023-12-08T20:11:50.230942Z	➀ YN0061: β”‚ workbox-range-requests@npm:6.6.1 is deprecated: this package has been deprecated
2023-12-08T20:11:50.248467Z	➀ YN0061: β”‚ workbox-background-sync@npm:6.6.1 is deprecated: this package has been deprecated
2023-12-08T20:11:50.322132Z	➀ YN0061: β”‚ workbox-cacheable-response@npm:6.6.1 is deprecated: [email protected]
2023-12-08T20:11:50.332208Z	➀ YN0061: β”‚ workbox-sw@npm:6.6.1 is deprecated: this package has been deprecated
2023-12-08T20:11:50.436275Z	➀ YN0032: β”‚ node-addon-api@npm:6.1.0: Implicit dependencies on node-gyp are discouraged
2023-12-08T20:11:52.134904Z	➀ YN0032: β”‚ fsevents@npm:2.3.2: Implicit dependencies on node-gyp are discouraged
2023-12-08T20:11:53.4935Z	➀ YN0061: β”‚ sourcemap-codec@npm:1.4.8 is deprecated: Please use @jridgewell/sourcemap-codec instead
2023-12-08T20:11:56.755897Z	➀ YN0061: β”‚ abab@npm:2.0.6 is deprecated: Use your platform's native atob() and btoa() methods instead
2023-12-08T20:11:56.923135Z	➀ YN0061: β”‚ domexception@npm:4.0.0 is deprecated: Use your platform's native DOMException instead
2023-12-08T20:11:58.070839Z	➀ YN0061: β”‚ stable@npm:0.1.8 is deprecated: Modern JS already guarantees Array#sort() is a stable sort, so this library is deprecated. See the compatibility table on MDN: https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Array/sort#browser_compatibility
2023-12-08T20:11:58.569397Z	➀ YN0061: β”‚ memfs@npm:3.6.0 is deprecated: this will be v4
2023-12-08T20:11:59.434411Z	➀ YN0061: β”‚ @npmcli/move-file@npm:1.1.2 is deprecated: This functionality has been moved to @npmcli/fs
2023-12-08T20:11:59.435471Z	➀ YN0061: β”‚ @npmcli/move-file@npm:2.0.1 is deprecated: This functionality has been moved to @npmcli/fs
2023-12-08T20:12:02.289651Z	➀ YN0032: β”‚ @parcel/watcher@npm:2.0.4: Implicit dependencies on node-gyp are discouraged
2023-12-08T20:12:02.295635Z	➀ YN0032: β”‚ node-addon-api@npm:3.2.1: Implicit dependencies on node-gyp are discouraged
2023-12-08T20:12:09.246865Z	➀ YN0002: β”‚ @algolia/autocomplete-core@npm:1.9.3 doesn't provide @algolia/client-search (pbc410), requested by @algolia/autocomplete-shared
2023-12-08T20:12:09.247359Z	➀ YN0002: β”‚ @algolia/autocomplete-core@npm:1.9.3 doesn't provide algoliasearch (p8ad5b), requested by @algolia/autocomplete-shared
2023-12-08T20:12:09.247659Z	➀ YN0002: β”‚ @algolia/autocomplete-core@npm:1.9.3 doesn't provide search-insights (pfdb70), requested by @algolia/autocomplete-plugin-algolia-insights
2023-12-08T20:12:09.247889Z	➀ YN0002: β”‚ @algolia/autocomplete-plugin-algolia-insights@npm:1.9.3 [e43f4] doesn't provide @algolia/client-search (pdf3b9), requested by @algolia/autocomplete-shared
2023-12-08T20:12:09.248128Z	➀ YN0002: β”‚ @algolia/autocomplete-plugin-algolia-insights@npm:1.9.3 [e43f4] doesn't provide algoliasearch (p0f6bb), requested by @algolia/autocomplete-shared
2023-12-08T20:12:09.248273Z	➀ YN0002: β”‚ @docsearch/react@npm:3.5.2 [0e4ac] doesn't provide @algolia/client-search (p796ce), requested by @algolia/autocomplete-preset-algolia
2023-12-08T20:12:09.248435Z	➀ YN0002: β”‚ @docsearch/react@npm:3.5.2 [635fe] doesn't provide @algolia/client-search (p0242f), requested by @algolia/autocomplete-preset-algolia
2023-12-08T20:12:09.24858Z	➀ YN0002: β”‚ @docusaurus/lqip-loader@workspace:packages/lqip-loader doesn't provide webpack (p6b2fd), requested by file-loader
2023-12-08T20:12:09.248723Z	➀ YN0002: β”‚ @docusaurus/plugin-ideal-image@workspace:packages/docusaurus-plugin-ideal-image doesn't provide prop-types (p317de), requested by @slorber/react-ideal-image
2023-12-08T20:12:09.248857Z	➀ YN0002: β”‚ @docusaurus/plugin-ideal-image@workspace:packages/docusaurus-plugin-ideal-image [86937] doesn't provide prop-types (p5ee07), requested by @slorber/react-ideal-image
2023-12-08T20:12:09.249001Z	➀ YN0002: β”‚ @docusaurus/theme-translations@workspace:packages/docusaurus-theme-translations doesn't provide react (pad908), requested by @docusaurus/core
2023-12-08T20:12:09.249142Z	➀ YN0002: β”‚ @docusaurus/theme-translations@workspace:packages/docusaurus-theme-translations doesn't provide react-dom (p165a7), requested by @docusaurus/core
2023-12-08T20:12:09.249277Z	➀ YN0002: β”‚ @docusaurus/utils@workspace:packages/docusaurus-utils doesn't provide react (pec387), requested by @docusaurus/types
2023-12-08T20:12:09.249441Z	➀ YN0002: β”‚ @docusaurus/utils@workspace:packages/docusaurus-utils doesn't provide react-dom (p21b4d), requested by @docusaurus/types
2023-12-08T20:12:09.249596Z	➀ YN0002: β”‚ @docusaurus/utils@workspace:packages/docusaurus-utils [331f5] doesn't provide react (p6b3c7), requested by @docusaurus/types
2023-12-08T20:12:09.249744Z	➀ YN0002: β”‚ @docusaurus/utils@workspace:packages/docusaurus-utils [331f5] doesn't provide react-dom (p1167a), requested by @docusaurus/types
2023-12-08T20:12:09.249876Z	➀ YN0002: β”‚ @lerna/legacy-package-management@npm:6.6.2 doesn't provide nx (pfc6c3), requested by @nrwl/devkit
2023-12-08T20:12:09.250003Z	➀ YN0002: β”‚ docusaurus-2-classic-template@workspace:packages/create-docusaurus/templates/classic doesn't provide @types/react (p7fe11), requested by @mdx-js/react
2023-12-08T20:12:09.250167Z	➀ YN0002: β”‚ docusaurus-2-classic-typescript-template@workspace:packages/create-docusaurus/templates/classic-typescript doesn't provide @types/react (pd38c2), requested by @mdx-js/react
2023-12-08T20:12:09.250305Z	➀ YN0060: β”‚ root@workspace:. provides @types/react (pe37bd) with version 18.2.15, which doesn't satisfy what @testing-library/react-hooks and some of its descendants request
2023-12-08T20:12:09.250453Z	➀ YN0060: β”‚ root@workspace:. provides react (p2b82c) with version 18.2.0, which doesn't satisfy what @testing-library/react-hooks and some of its descendants request
2023-12-08T20:12:09.250614Z	➀ YN0060: β”‚ root@workspace:. provides react-dom (p14806) with version 18.2.0, which doesn't satisfy what @testing-library/react-hooks requests
2023-12-08T20:12:09.250751Z	➀ YN0060: β”‚ root@workspace:. provides react-test-renderer (p5dd7f) with version 18.2.0, which doesn't satisfy what @testing-library/react-hooks requests
2023-12-08T20:12:09.250881Z	➀ YN0002: β”‚ website@workspace:website doesn't provide eslint (pf4c4c), requested by @docusaurus/eslint-plugin
2023-12-08T20:12:09.251011Z	➀ YN0000: β”‚ Some peer dependencies are incorrectly met; run yarn explain peer-requirements <hash> for details, where <hash> is the six-letter p-prefixed code
2023-12-08T20:12:09.254047Z	➀ YN0000: β”” Completed in 23s 397ms
2023-12-08T20:12:09.402514Z	➀ YN0000: β”Œ Post-resolution validation
2023-12-08T20:12:09.402888Z	➀ YN0028: β”‚ The lockfile would have been modified by this install, which is explicitly forbidden.
2023-12-08T20:12:09.403114Z	➀ YN0000: β”” Completed
2023-12-08T20:12:09.403268Z	➀ YN0000: Failed with errors in 23s 550ms
2023-12-08T20:12:09.525352Z	Error: Exit with error code: 1
2023-12-08T20:12:09.531111Z	    at ChildProcess.<anonymous> (/snapshot/dist/run-build.js)
2023-12-08T20:12:09.531331Z	    at Object.onceWrapper (node:events:652:26)
2023-12-08T20:12:09.531508Z	    at ChildProcess.emit (node:events:537:28)
2023-12-08T20:12:09.531818Z	    at ChildProcess._handle.onexit (node:internal/child_process:291:12)
2023-12-08T20:12:09.53496Z	Failed: build command exited with code: 1
2023-12-08T20:12:10.520897Z	Failed: error occurred while running build command

My configuration when create project:

Framework preset Build command Build directory
Docusaurus npm run build build

Please help me, how I can fix it? :pray:

Add an env var YARN_VERSION with the value 1

Failed :frowning:

Logs (only end, I can’t add full text):

23:31:14.558	Cloning repository...
23:31:16.902	warning: redirecting to https://gitlab.com/myaccount/docusaurus.git/
23:31:16.903	From https://gitlab.com/myaccount/docusaurus
23:31:16.903	 * branch            d3752d227b67bf0eeccc89e9c05f033c9e2c56c9 -> FETCH_HEAD
23:31:16.903	
23:31:18.010	HEAD is now at d3752d2 feat(core): enable port configuration via environment variable (#9610)
23:31:18.012	
23:31:18.139	
23:31:18.174	Success: Finished cloning repository files
23:31:19.036	Detected the following tools from environment: [email protected], [email protected]
23:31:19.459	Preparing [email protected] for immediate activation...
23:31:20.354	Installing project dependencies: yarn --pure-lockfile --no-progress --emoji false
23:31:21.052	yarn install v1.22.19
23:31:21.258	[1/4] Resolving packages...
23:31:21.950	[2/4] Fetching packages...
23:32:09.905	[3/4] Linking dependencies...
23:32:09.910	warning " > @testing-library/[email protected]" has incorrect peer dependency "react@^16.9.0 || ^17.0.0".
23:32:09.917	warning "workspace-aggregator-2806b3dc-dfe6-4053-a857-9d1f6f4bcdea > @docusaurus/plugin-ideal-image > @slorber/[email protected]" has unmet peer dependency "prop-types@>=15".
23:32:09.922	warning "workspace-aggregator-2806b3dc-dfe6-4053-a857-9d1f6f4bcdea > @docusaurus/theme-search-algolia > @docsearch/react > @algolia/[email protected]" has unmet peer dependency "@algolia/client-search@>= 4.9.1 < 6".
23:32:09.925	warning "workspace-aggregator-2806b3dc-dfe6-4053-a857-9d1f6f4bcdea > @docusaurus/theme-search-algolia > @docsearch/react > @algolia/autocomplete-core > @algolia/[email protected]" has unmet peer dependency "search-insights@>= 1 < 3".
23:32:09.925	warning "workspace-aggregator-2806b3dc-dfe6-4053-a857-9d1f6f4bcdea > @docusaurus/theme-search-algolia > @docsearch/react > @algolia/autocomplete-core > @algolia/[email protected]" has unmet peer dependency "@algolia/client-search@>= 4.9.1 < 6".
23:32:09.965	warning Workspaces can only be enabled in private projects.
23:32:10.004	warning Workspaces can only be enabled in private projects.
23:32:48.355	[4/4] Building fresh packages...
23:32:55.275	$ yarn lock:update && yarn build:packages
23:32:55.621	yarn run v1.22.19
23:32:55.662	$ npx --yes yarn-deduplicate
23:33:01.182	Done in 5.57s.
23:33:01.414	yarn run v1.22.19
23:33:01.457	$ lerna run build --no-private
23:33:03.433	lerna notice cli v6.6.2
23:33:03.441	lerna info ci enabled
23:33:03.523	lerna info Executing command in 30 packages: "yarn run build"
23:33:09.124	lerna info run Ran npm script 'build' in '@docusaurus/cssnano-preset' in 5.6s:
23:33:09.125	$ tsc
23:33:09.194	lerna info run Ran npm script 'build' in '@docusaurus/utils-common' in 5.6s:
23:33:09.194	$ tsc
23:33:09.319	lerna info run Ran npm script 'build' in '@docusaurus/logger' in 5.8s:
23:33:09.319	$ tsc
23:33:09.366	lerna info run Ran npm script 'build' in '@docusaurus/remark-plugin-npm2yarn' in 5.8s:
23:33:09.366	$ tsc
23:33:15.057	lerna info run Ran npm script 'build' in '@docusaurus/lqip-loader' in 5.7s:
23:33:15.063	$ tsc
23:33:15.080	lerna info run Ran npm script 'build' in 'stylelint-copyright' in 5.9s:
23:33:15.081	$ tsc
23:33:15.746	lerna info run Ran npm script 'build' in '@docusaurus/utils' in 6.4s:
23:33:15.746	$ tsc
23:33:15.774	lerna info run Ran npm script 'build' in '@docusaurus/eslint-plugin' in 6.6s:
23:33:15.774	$ tsc
23:33:19.278	lerna info run Ran npm script 'build' in 'create-docusaurus' in 3.5s:
23:33:19.279	$ tsc --build
23:33:19.318	lerna info run Ran npm script 'build' in '@docusaurus/utils-validation' in 3.6s:
23:33:19.319	$ tsc
23:33:22.171	lerna info run Ran npm script 'build' in '@docusaurus/mdx-loader' in 2.9s:
23:33:22.171	$ tsc
23:33:30.579	lerna info run Ran npm script 'build' in '@docusaurus/core' in 8.4s:
23:33:30.579	$ tsc --build && node ../../admin/scripts/copyUntypedFiles.js
23:33:36.751	lerna info run Ran npm script 'build' in '@docusaurus/plugin-client-redirects' in 6.2s:
23:33:36.751	$ tsc
23:33:37.029	lerna info run Ran npm script 'build' in '@docusaurus/plugin-content-pages' in 6.4s:
23:33:37.029	$ tsc
23:33:37.942	lerna info run Ran npm script 'build' in '@docusaurus/plugin-content-blog' in 7.3s:
23:33:37.942	$ tsc
23:33:42.385	lerna info run Ran npm script 'build' in '@docusaurus/plugin-content-docs' in 11.8s:
23:33:42.385	$ tsc --build
23:33:46.035	lerna info run Ran npm script 'build' in '@docusaurus/plugin-google-analytics' in 9.0s:
23:33:46.036	$ tsc --build
23:33:46.796	lerna info run Ran npm script 'build' in '@docusaurus/plugin-google-gtag' in 8.9s:
23:33:46.796	$ tsc --build
23:33:47.320	lerna info run Ran npm script 'build' in '@docusaurus/plugin-debug' in 10.6s:
23:33:47.320	$ tsc --build && node ../../admin/scripts/copyUntypedFiles.js && prettier --config ../../.prettierrc --write "lib/theme/**/*.js"
23:33:47.320	lib/theme/DebugConfig/index.js 95ms
23:33:47.320	lib/theme/DebugContent/index.js 40ms
23:33:47.320	lib/theme/DebugGlobalData/index.js 6ms
23:33:47.320	lib/theme/DebugJsonView/index.js 33ms
23:33:47.322	lib/theme/DebugLayout/index.js 15ms
23:33:47.322	lib/theme/DebugRegistry/index.js 19ms
23:33:47.322	lib/theme/DebugRoutes/index.js 19ms
23:33:47.322	lib/theme/DebugSiteMetadata/index.js 15ms
23:33:50.452	lerna info run Ran npm script 'build' in '@docusaurus/plugin-google-tag-manager' in 8.1s:
23:33:50.453	$ tsc --build
23:33:51.734	lerna info run Ran npm script 'build' in '@docusaurus/plugin-sitemap' in 5.7s:
23:33:51.734	$ tsc
23:33:52.147	lerna info run Ran npm script 'build' in '@docusaurus/theme-translations' in 5.4s:
23:33:52.147	$ tsc --build
23:33:55.419	lerna info run Ran npm script 'build' in '@docusaurus/theme-common' in 8.1s:
23:33:55.420	$ tsc && node ../../admin/scripts/copyUntypedFiles.js
23:34:00.109	lerna info run Ran npm script 'build' in '@docusaurus/plugin-ideal-image' in 8.0s:
23:34:00.109	$ tsc --build && node ../../admin/scripts/copyUntypedFiles.js && prettier --config ../../.prettierrc --write "lib/theme/**/*.js"
23:34:00.109	lib/theme/IdealImage/index.js 136ms
23:34:07.090	lerna info run Ran npm script 'build' in '@docusaurus/plugin-pwa' in 11.7s:
23:34:07.090	$ tsc --build && node ../../admin/scripts/copyUntypedFiles.js && prettier --config ../../.prettierrc --write "lib/theme/**/*.js"
23:34:07.090	lib/theme/PwaReloadPopup/index.js 173ms
23:34:07.887	lerna info run Ran npm script 'build' in '@docusaurus/theme-live-codeblock' in 12.4s:
23:34:07.888	$ tsc --build && node ../../admin/scripts/copyUntypedFiles.js && prettier --config ../../.prettierrc --write "lib/theme/**/*.js"
23:34:07.889	lib/theme/CodeBlock/index.js 86ms
23:34:07.889	lib/theme/Playground/index.js 60ms
23:34:07.889	lib/theme/ReactLiveScope/index.js 4ms
23:34:09.869	lerna info run Ran npm script 'build' in '@docusaurus/theme-mermaid' in 9.8s:
23:34:09.869	$ tsc --build && node ../../admin/scripts/copyUntypedFiles.js && prettier --config ../../.prettierrc --write "lib/theme/**/*.js"
23:34:09.869	lib/theme/Mermaid/index.js 95ms
23:34:14.211	lerna info run Ran npm script 'build' in '@docusaurus/theme-classic' in 18.8s:
23:34:14.211	$ tsc --build && node ../../admin/scripts/copyUntypedFiles.js && prettier --config ../../.prettierrc --write "lib/theme/**/*.js"
23:34:14.211	lib/theme/Admonition/Icon/Danger.js 67ms
23:34:14.211	lib/theme/Admonition/Icon/Info.js 6ms
23:34:14.212	lib/theme/Admonition/Icon/Note.js 5ms
23:34:14.212	lib/theme/Admonition/Icon/Tip.js 5ms
23:34:14.213	lib/theme/Admonition/Icon/Warning.js 5ms
23:34:14.213	lib/theme/Admonition/index.js 13ms
23:34:14.213	lib/theme/Admonition/Layout/index.js 16ms
23:34:14.213	lib/theme/Admonition/Type/Caution.js 8ms
23:34:14.213	lib/theme/Admonition/Type/Danger.js 6ms
23:34:14.213	lib/theme/Admonition/Type/Info.js 7ms
23:34:14.213	lib/theme/Admonition/Type/Note.js 5ms
23:34:14.213	lib/theme/Admonition/Type/Tip.js 4ms
23:34:14.213	lib/theme/Admonition/Type/Warning.js 6ms
23:34:14.213	lib/theme/Admonition/Types.js 9ms
23:34:14.213	lib/theme/AnnouncementBar/CloseButton/index.js 7ms
23:34:14.214	lib/theme/AnnouncementBar/Content/index.js 5ms
23:34:14.214	lib/theme/AnnouncementBar/index.js 12ms
23:34:14.214	lib/theme/BackToTopButton/index.js 6ms
23:34:14.216	lib/theme/BlogArchivePage/index.js 21ms
23:34:14.216	lib/theme/BlogLayout/index.js 7ms
23:34:14.216	lib/theme/BlogListPage/index.js 8ms
23:34:14.216	lib/theme/BlogListPaginator/index.js 4ms
23:34:14.216	lib/theme/BlogPostItem/Container/index.js 6ms
23:34:14.216	lib/theme/BlogPostItem/Content/index.js 4ms
23:34:14.216	lib/theme/BlogPostItem/Footer/index.js 9ms
23:34:14.216	lib/theme/BlogPostItem/Footer/ReadMoreLink/index.js 7ms
23:34:14.216	lib/theme/BlogPostItem/Header/Author/index.js 23ms
23:34:14.216	lib/theme/BlogPostItem/Header/Authors/index.js 29ms
23:34:14.216	lib/theme/BlogPostItem/Header/index.js 2ms
23:34:14.216	lib/theme/BlogPostItem/Header/Info/index.js 8ms
23:34:14.216	lib/theme/BlogPostItem/Header/Title/index.js 6ms
23:34:14.216	lib/theme/BlogPostItem/index.js 4ms
23:34:14.216	lib/theme/BlogPostItems/index.js 3ms
23:34:14.217	lib/theme/BlogPostPage/index.js 7ms
23:34:14.217	lib/theme/BlogPostPage/Metadata/index.js 7ms
23:34:14.217	lib/theme/BlogPostPaginator/index.js 10ms
23:34:14.217	lib/theme/BlogSidebar/Desktop/index.js 10ms
23:34:14.217	lib/theme/BlogSidebar/index.js 4ms
23:34:14.217	lib/theme/BlogSidebar/Mobile/index.js 5ms
23:34:14.217	lib/theme/BlogTagsListPage/index.js 4ms
23:34:14.217	lib/theme/BlogTagsPostsPage/index.js 8ms
23:34:14.218	lib/theme/CodeBlock/Container/index.js 4ms
23:34:14.218	lib/theme/CodeBlock/Content/Element.js 3ms
23:34:14.218	lib/theme/CodeBlock/Content/String.js 16ms
23:34:14.218	lib/theme/CodeBlock/CopyButton/index.js 6ms
23:34:14.218	lib/theme/CodeBlock/index.js 5ms
23:34:14.218	lib/theme/CodeBlock/Line/index.js 7ms
23:34:14.218	----- TRUNCATED - click "Download log" to view more logs
----- Tailing last 100 lines:
23:34:56.478	lib/theme/NavbarItem/DocsVersionDropdownNavbarItem.js 8ms
23:34:56.478	lib/theme/NavbarItem/DocsVersionNavbarItem.js 3ms
23:34:56.479	lib/theme/NavbarItem/DropdownNavbarItem/index.js 11ms
23:34:56.479	lib/theme/NavbarItem/HtmlNavbarItem.js 2ms
23:34:56.479	lib/theme/NavbarItem/index.js 3ms
23:34:56.479	lib/theme/NavbarItem/LocaleDropdownNavbarItem/index.js 6ms
23:34:56.479	lib/theme/NavbarItem/NavbarNavLink.js 5ms
23:34:56.479	lib/theme/NavbarItem/SearchNavbarItem.js 2ms
23:34:56.479	lib/theme/NotFound/Content/index.js 4ms
23:34:56.479	lib/theme/NotFound/index.js 3ms
23:34:56.480	lib/theme/PaginatorNavLink/index.js 3ms
23:34:56.480	lib/theme/prism-include-languages.js 3ms
23:34:56.480	lib/theme/SearchBar.js 2ms
23:34:56.480	lib/theme/SearchMetadata/index.js 4ms
23:34:56.480	lib/theme/SiteMetadata/index.js 11ms
23:34:56.480	lib/theme/SkipToContent/index.js 2ms
23:34:56.480	lib/theme/TabItem/index.js 2ms
23:34:56.480	lib/theme/Tabs/index.js 11ms
23:34:56.481	lib/theme/Tag/index.js 3ms
23:34:56.481	lib/theme/TagsListByLetter/index.js 4ms
23:34:56.481	lib/theme/TagsListInline/index.js 4ms
23:34:56.481	lib/theme/ThemedImage/index.js 2ms
23:34:56.481	lib/theme/TOC/index.js 3ms
23:34:56.481	lib/theme/TOCCollapsible/CollapseButton/index.js 3ms
23:34:56.481	lib/theme/TOCCollapsible/index.js 3ms
23:34:56.482	lib/theme/TOCInline/index.js 2ms
23:34:56.482	lib/theme/TOCItems/index.js 3ms
23:34:56.482	lib/theme/TOCItems/Tree.js 4ms
23:34:56.482	lib/theme/Unlisted/index.js 3ms
23:34:59.460	lerna info run Ran npm script 'build' in '@docusaurus/preset-classic' in 3.0s:
23:34:59.461	$ tsc
23:34:59.461	lerna success run Ran npm script 'build' in 30 packages in 37.4s:
23:34:59.461	lerna success - create-docusaurus
23:34:59.462	lerna success - @docusaurus/cssnano-preset
23:34:59.462	lerna success - @docusaurus/logger
23:34:59.462	lerna success - @docusaurus/mdx-loader
23:34:59.462	lerna success - @docusaurus/plugin-client-redirects
23:34:59.462	lerna success - @docusaurus/plugin-content-blog
23:34:59.462	lerna success - @docusaurus/plugin-content-docs
23:34:59.462	lerna success - @docusaurus/plugin-content-pages
23:34:59.463	lerna success - @docusaurus/plugin-debug
23:34:59.463	lerna success - @docusaurus/plugin-google-analytics
23:34:59.463	lerna success - @docusaurus/plugin-google-gtag
23:34:59.463	lerna success - @docusaurus/plugin-google-tag-manager
23:34:59.463	lerna success - @docusaurus/plugin-ideal-image
23:34:59.463	lerna success - @docusaurus/plugin-pwa
23:34:59.463	lerna success - @docusaurus/plugin-sitemap
23:34:59.463	lerna success - @docusaurus/preset-classic
23:34:59.464	lerna success - @docusaurus/remark-plugin-npm2yarn
23:34:59.464	lerna success - @docusaurus/theme-classic
23:34:59.464	lerna success - @docusaurus/theme-common
23:34:59.464	lerna success - @docusaurus/theme-live-codeblock
23:34:59.464	lerna success - @docusaurus/theme-mermaid
23:34:59.464	lerna success - @docusaurus/theme-search-algolia
23:34:59.464	lerna success - @docusaurus/theme-translations
23:34:59.465	lerna success - @docusaurus/utils-common
23:34:59.465	lerna success - @docusaurus/utils-validation
23:34:59.465	lerna success - @docusaurus/utils
23:34:59.465	lerna success - @docusaurus/core
23:34:59.465	lerna success - @docusaurus/eslint-plugin
23:34:59.465	lerna success - @docusaurus/lqip-loader
23:34:59.465	lerna success - stylelint-copyright
23:34:59.482	Done in 39.58s.
23:34:59.798	yarn run v1.22.19
23:34:59.835	$ yarn workspace website build
23:35:00.546	$ docusaurus build
23:35:04.420	[INFO] Website will be built for all these locales: 
23:35:04.421	- en
23:35:04.421	- fr
23:35:04.421	- pt-BR
23:35:04.421	- ko
23:35:04.422	- zh-CN
23:35:04.422	[INFO] [en] Creating an optimized production build...
23:35:37.668	[info] [webpackbar] Compiling Client
23:35:37.698	[info] [webpackbar] Compiling Server
23:38:21.367	[success] [webpackbar] Client: Compiled successfully in 2.73m
23:38:59.687	[success] [webpackbar] Server: Compiled successfully in 3.37m
23:39:17.992	[info] [webpackbar] Compiling Service Worker
23:39:19.662	[success] [webpackbar] Service Worker: Compiled successfully in 1.67s
23:39:25.514	[SUCCESS] Generated static files in "build".
23:39:25.515	[INFO] [fr] Creating an optimized production build...
23:40:30.469	[info] [webpackbar] Compiling Client
23:40:30.480	[info] [webpackbar] Compiling Server
23:43:25.423	[success] [webpackbar] Client: Compiled successfully in 2.92m
23:43:42.667	Segmentation fault
23:43:42.682	error Command failed with exit code 139.
23:43:42.682	info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
23:43:42.705	error Command failed.
23:43:42.706	Exit code: 139
23:43:42.706	Command: /opt/buildhome/.asdf/installs/nodejs/18.17.1/bin/node
23:43:42.707	Arguments: /opt/buildhome/.cache/node/corepack/yarn/1.22.19/lib/cli.js build
23:43:42.707	Directory: /opt/buildhome/repo/website
23:43:42.707	Output:
23:43:42.708	
23:43:42.708	info Visit https://yarnpkg.com/en/docs/cli/workspace for documentation about this command.
23:43:42.737	error Command failed with exit code 139.
23:43:42.738	info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
23:43:42.767	Failed: Error while executing user command. Exited with error code: 139
23:43:42.780	Failed: build command exited with code: 1
23:43:44.190	Failed: error occurred while running build command
23:43:44.190	Note: Not all logs could be displayed, click "Download log" to view more

For the test I was change branch from main to docusaurus-v2 with env var YARN_VERSION with the value 1, and now get this error:

00:53:17.255	lerna success - stylelint-copyright
00:53:17.255	Done in 39.36s.
00:53:17.578	yarn run v1.22.19
00:53:17.618	$ yarn workspace website build
00:53:18.348	$ docusaurus build
00:53:21.140	[INFO] Website will be built for all these locales: 
00:53:21.141	- en
00:53:21.141	- fr
00:53:21.141	- pt-BR
00:53:21.141	- ko
00:53:21.141	- zh-CN
00:53:21.141	[INFO] [en] Creating an optimized production build...
00:53:50.066	Browserslist: caniuse-lite is outdated. Please run:
00:53:50.066	  npx update-browserslist-db@latest
00:53:50.066	  Why you should do it regularly: https://github.com/browserslist/update-db#readme
00:53:50.183	[info] [webpackbar] Compiling Client
00:53:50.210	[info] [webpackbar] Compiling Server
00:55:32.677	Browserslist: caniuse-lite is outdated. Please run:
00:55:32.678	  npx update-browserslist-db@latest
00:55:32.679	  Why you should do it regularly: https://github.com/browserslist/update-db#readme
00:55:35.257	[success] [webpackbar] Client: Compiled successfully in 1.75m
00:55:50.182	Component APITable was not imported, exported, or provided by MDXProvider as global scope
00:55:55.308	Component APITable was not imported, exported, or provided by MDXProvider as global scope
00:56:01.546	[success] [webpackbar] Server: Compiled successfully in 2.19m
00:56:16.996	[info] [webpackbar] Compiling Service Worker
00:56:18.874	[success] [webpackbar] Service Worker: Compiled successfully in 1.88s
00:56:23.401	[SUCCESS] Generated static files in "build".
00:56:23.401	[INFO] [fr] Creating an optimized production build...
00:57:06.738	[info] [webpackbar] Compiling Client
00:57:06.748	[info] [webpackbar] Compiling Server
00:58:49.960	Browserslist: caniuse-lite is outdated. Please run:
00:58:49.961	  npx update-browserslist-db@latest
00:58:49.961	  Why you should do it regularly: https://github.com/browserslist/update-db#readme
00:58:52.500	[success] [webpackbar] Client: Compiled successfully in 1.76m
00:59:07.740	Component APITable was not imported, exported, or provided by MDXProvider as global scope
00:59:12.988	Component APITable was not imported, exported, or provided by MDXProvider as global scope
00:59:19.799	[success] [webpackbar] Server: Compiled successfully in 2.22m
00:59:35.848	[info] [webpackbar] Compiling Service Worker
00:59:37.547	[success] [webpackbar] Service Worker: Compiled successfully in 1.70s
00:59:41.994	[SUCCESS] Generated static files in "build/fr".
00:59:41.995	[INFO] [pt-BR] Creating an optimized production build...
01:00:29.370	[info] [webpackbar] Compiling Client
01:00:29.380	[info] [webpackbar] Compiling Server
01:02:15.930	Browserslist: caniuse-lite is outdated. Please run:
01:02:15.931	  npx update-browserslist-db@latest
01:02:15.931	  Why you should do it regularly: https://github.com/browserslist/update-db#readme
01:02:18.534	[success] [webpackbar] Client: Compiled successfully in 1.82m
01:02:34.837	Component APITable was not imported, exported, or provided by MDXProvider as global scope
01:02:40.227	Component APITable was not imported, exported, or provided by MDXProvider as global scope
01:02:47.565	[success] [webpackbar] Server: Compiled successfully in 2.30m
01:03:04.488	[info] [webpackbar] Compiling Service Worker
01:03:07.137	[success] [webpackbar] Service Worker: Compiled successfully in 2.65s
01:03:11.673	[SUCCESS] Generated static files in "build/pt-BR".
01:03:11.673	[INFO] [ko] Creating an optimized production build...
01:04:02.801	[info] [webpackbar] Compiling Client
01:04:02.812	[info] [webpackbar] Compiling Server
01:05:54.981	Browserslist: caniuse-lite is outdated. Please run:
01:05:54.982	  npx update-browserslist-db@latest
01:05:54.982	  Why you should do it regularly: https://github.com/browserslist/update-db#readme
01:05:57.400	[success] [webpackbar] Client: Compiled successfully in 1.91m
01:06:03.839	For locale=ko, a maximum of 1 plural forms are expected (other), but the message contains 2: 1 site|273 sites
01:06:14.064	Component APITable was not imported, exported, or provided by MDXProvider as global scope
01:06:19.598	Component APITable was not imported, exported, or provided by MDXProvider as global scope
01:06:27.476	[success] [webpackbar] Server: Compiled successfully in 2.41m
01:06:45.385	[info] [webpackbar] Compiling Service Worker
01:06:48.536	[success] [webpackbar] Service Worker: Compiled successfully in 3.15s
01:06:53.187	[SUCCESS] Generated static files in "build/ko".
01:06:53.188	[INFO] [zh-CN] Creating an optimized production build...
01:07:49.149	[info] [webpackbar] Compiling Client
01:07:49.159	[info] [webpackbar] Compiling Server
01:09:48.441	Browserslist: caniuse-lite is outdated. Please run:
01:09:48.451	  npx update-browserslist-db@latest
01:09:48.451	  Why you should do it regularly: https://github.com/browserslist/update-db#readme
01:09:50.808	[success] [webpackbar] Client: Compiled successfully in 2.03m
01:10:03.665	For locale=zh-CN, a maximum of 1 plural forms are expected (other), but the message contains 2: 1 site|273 sites
01:10:27.763	Component APITable was not imported, exported, or provided by MDXProvider as global scope
01:10:33.483	Component APITable was not imported, exported, or provided by MDXProvider as global scope
01:10:51.263	[success] [webpackbar] Server: Compiled successfully in 3.04m
01:11:16.703	[info] [webpackbar] Compiling Service Worker
01:11:18.827	[success] [webpackbar] Service Worker: Compiled successfully in 2.12s
01:11:26.388	[SUCCESS] Generated static files in "build/zh-CN".
01:11:26.388	[INFO] Use `npm run serve` command to test your build locally.
01:11:26.752	Done in 1089.18s.
01:11:26.803	Finished
01:11:26.803	Note: No functions dir at /functions found. Skipping.
01:11:26.803	Validating asset output directory
01:11:26.805	Error: Output directory "build" not found.
01:11:28.165	Failed: build output directory not found
01:11:28.165	Note: Not all logs could be displayed, click "Download log" to view more