Dockers lose connectivity when enable WARP


My docker containers lose connectivity to the internet when I enable WARP on my Ubuntu machine.

I am using WARP ZeroTrust with Split Tunneling and I’ve tried WARP+ from my iOS account.

My /etc/docker/daemon.json looks like this:

    "default-runtime": "nvidia",
    "runtimes": {
        "nvidia": {
            "args": [],
            "path": "nvidia-container-runtime"
    "storage-driver": "zfs",
    "dns": ["", ""]

I am using WARP+DOH as the Mode.
I included the Docker Network in my split tunnel.

Dockers all works fine if I disconnect WARP. I tried both Bridge and Host mode, some of the dockers work in Host mode but I’d rather not change everything.

I should also mention I am using Docker Compose to launch my dockers.

You’ve encountered connectivity issues with Docker containers when using Cloudflare WARP with Split Tunneling enabled. This kind of issue can sometimes arise due to the way networking is configured when using VPNs and tunneling services like WARP.

Verify your WARP settings to make sure you’re not inadvertently routing Docker traffic through the tunnel. Double-check the split tunnel configuration and ensure that the Docker-related IP ranges are included.

I want the dockers to use WARP when they communicate to the outside world, they just can’t seemingly resolve the DNS or ping the outside world.

Turns out I needed to delete the DNS, it was causing the issues.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.