Do not want https on subdomains

Hi. How can I disable https on my subdomains. When using Cloudflare it keeps redirecting me from http to https even though I have disabled always https.

I still want https on my mainsite though

1 Like

Hi @kryji,

If you have disabled the ‘Always use HTTPS’ setting, it should not redirect to HTTPS, I suspect the redirect may be cached at your end.

You can use page rules to set the SSL mode for the subdomains to Off if you don’t want HTTPS there at all. You could also use a page rule to force HTTPS on the main site.

@domjh hey thanks for the reply. I cleared cache and it works. But as soon as I visit the main website again it stops working on the subdomain.

try it yourself

http works fine if you clear cache. But if you visit the main website, it stops working again

I see an issue on your origin server with the certificate and ssl is set to Full(Strict) on the SSL/TLS app, can you set it to Full and see if the error goes away?

I have set it on full now but the error is still there

Got it, thank you. I suspect it would be best to get ssl functioning and then worry about disabling it on the sub-directory. With Full, I am able to load with ssl in place but suspect the always use https page rule is introducing an issue that causes "ERR_CONNEC《edit》 when I tried on the subdirectory.

What do you mean? is the main website not working for you? It is working just fine for me. I tried with browseling too.

Also the is not going through Cloudflare, it has a gray cloud. The two are also hosted on seperate servers.

@cloonan I have disabled always https. What should I do. I want https everywhere except on the sudomain, apache. The ssl setting should not matter since it is not routed through Cloudflare anyway?

I do not understand why the http is still getting directed to https.

I was just going to comment about the redirect, it may be from the origin but am digging into your settings a bit more…

1 Like

If a record is :grey: no Cloudflare setting impacts it. The configuration that needs to be managed for https or not is on your origin server.


The apache server/sub-directory does not accept traffic on port 443 and the symptoms have not changed, loads without ssl, go to the page loads with ssl in place, go to and you’re forced to with an error ERR_CONNECTION_REFUSED. I don’t think it’s a cache page but is happening on your origin.


Yeah I think I found the issue. In my nginx config I had this add_header Strict-Transport-Security "max-age=31536000; includeSubDomains; preload" always;

Anyways I removed includeSubDomains and cleared cache and this time both sites worked… until today when they stopped working again :(. I will have to look around in the configurations, strange nevertheless.

After I cleared nginx cache & removed Referrer-Policy it works again. Can you confirm this on your end as well @cloonan? Thanks for everything :slight_smile: (damn apache mirror needing http)

1 Like

Yes, I’m seeing the issue again. If you don’t mind, @kryji, can you loop in support? To contact Cloudflare Customer Support, login & go to and select get more help. If you can share the ticket number I’ll follow it in support with the team.

also yes I just confirmed that it is due to Cloudflare I think? When I am in development mode it works just fine, but the stops working/gets redirected once I exit development mode.

as @cs-cf said. If a record is :grey: no Cloudflare setting impacts it. The configuration that needs to be managed for https or not is on your origin server.

so it gets even more strange since is on gray cloud, and only goes through Cloudflare.

Okay ticket number is 1723669

1 Like

Thank you, I see the ticket. Can you respond to the auto reply you received and let the engineer know you’re still encountering the issue?

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.