Do Not Redirect to Https for Some Url

I’m curious what I’m doing wrong. I don’t want /.well-known/acme-challenge get redirected to https. Below is what I did

Page Rules:

*mydomain.com/.well-known/acme-challenge
SSL: Off

http:// mydomain.com/
Always Use HTTPS

SSL/TLS > Edge Certificates > Always Use HTTPS - OFF

Now doing this:

curl …the url with http
still gives me

HTTP/1.1 301 Moved Permanently

Location: https…

Any idea? I’m curious what am I doing wrong. Do i need to wait for some time?

Thanks

What’s the domain and can you post a screenshot of your page rule list?

Hi,

See below:

Removing the second rule, still redirects me to https…

turn off https redirect config

This setting seems does not have any effect at all

That redirect most likely comes from your server. Check there too.

Seems to work though

$ curl -I http://reactsvgicons.com/.well-known/acme-challenge
HTTP/1.1 404 Not Found
Content-Type: application/json; charset=utf-8
Content-Length: 52
Connection: keep-alive
Access-Control-Allow-Origin: *
Access-Control-Allow-Headers: Authorization, Accept, Content-Type
Access-Control-Allow-Methods: OPTIONS, GET, POST, PUT, PATCH, DELETE
CF-Cache-Status: DYNAMIC
Server: cloudflare

@sandro yeah you are correct it was my server that does the redirect. I thought cloudflare does not pass that url and apply rule first. I just directly switch to vercel and works now.

Thanks for the hint.

It does apply the rule, however it will still pass it on to your server where it then got redirected.

This topic was automatically closed after 31 days. New replies are no longer allowed.