DNSSEC while using CF NS

I’m trying to activate DNSSEC, but having trouble,
I tried the simple wat…DNS > Settings Slide on, but the I get the instructions to enter DNS entries with my Registrar, but since I’m using CF Nameserver, I can’t access de DNS settings with my registrar.
So I tried adding a DS record, but that doesn’t work either, saying its a DNS validation error and I need to go to my registrar. With my old registrar, when I turned on DNSSEC, I could no longer use CF…

Rock…Pickle…Hard place…

DS records are served together with the nameservers, so that is something that you need to set at your registrar, just like the nameservers.

If your registrar doesn’t allow you to set a DS record after changing your nameservers, you will not be able to use DNSSEC.

From the CloudFlare Knowledgebase

If you are onboarding an existing domain to Cloudflare, make sure DNSSEC is disabled at your registrar (where you purchased your domain name). Otherwise, your domain will experience connectivity errors when you change your nameservers.

So that would pose a problem right?
First disable DNSSEC, move over dan than…
reenable, but how?
The only option I have turn on DNSSEc at mij Registrar (mijn.host), enter the algorithm, flag an public key, done that but CF does not see that it seems…so now what?

:point_up: