DNSSEC still not working on Cloudflare Registrar

I ran into this issue 2 years ago when Cloudflare Registrar first launched… and it looks like it’s still an issue. The dreaded “DNSSEC is pending while we wait for the DS to be added to your registrar” message which never goes away. You can wait 200 hours, enable/disable DNSSEC a million times and your domain will still never have DNSSEC.

On the Cloudflare Registrar product page “one-click DNSSEC” is advertised as one of the many benefits, but I’ve clicked a dozen times now and waited many hours. DNSSEC is easier to implement when using an outside registrar.

This was acknowledged as a known issue back in Dec, 2018 here: Stuck Pending While Setting Up DNSSEC On Cloudflare Registrar

Also, a slew of very basic registrar features are still missing from Cloudflare Registrar more than 2 years after its launch:

  1. Ability to purchase/register new domains
  2. Ability to make WHOIS public (not everyone wants redaction)
  3. Ability to “add years” to a domain rather than wait for auto-renewal

It’s insanely awesome that you guys are launching groundbreaking products like Cloudflare One but please don’t forget about the products you’ve already launched in the process. I realize Cloudflare Registrar is a “loss leader” and as such has probably been put on the back burner, but when basic functionality within a core product is broken it truly does reflect poorly upon the Cloudflare brand as a whole.

Hmm, you can actually “add years”. I did some time ago and paid for two domains until 2025. The maximum number of years may depend on the tld (I had .org and .email).

As for (1) and (2), I don’t know.

I’m almost positive you can’t. If it’s possible, the feature is extremely well hidden.

Do you remember how you were able to add years to the registration period? I suspect you’re confused and added them before transferring to Cloudflare Registrar.

Edit: Looks like you can “add years” now! This must have been added recently!