DNSSEC needs fixing on cloudflare registrar


#1

Just transferred a domain to Cloudflare registrar and tried enabling DNSSEC.

What I expected to happen is for the DS record to be created automatically, perhaps that was a little optimistic:grin: Anyway I then discovered I have to do it manually but that causes two problems.

  1. The fields on the DS record provided by Cloudflare do not match the fields on the add DS dialogue
  2. The add DS record pops up one of those horrible javascript forms that prevents you from copying and pasting the data.

To try and work around this I had top open 2 copies of the same cloudflare page to paste information from cloudflare, to cloudflare. I failed to get it to work and gave up in the end but this is an amusing UI faux pass. There really needs to be an update where cloudflare recognizes that the domain is hosted on and registered with cloudflare and either automatically create the DS record or provide a button that offers to add the record to the DNS.


#2

#3

Is there any way to fix it ourselves?


#4

I’m going to guess not, given that the existing tool was designed prior to Cloudflare offering registrar services. They probably both need to update the DNS module of the dashboard AND the DNSSEC process. Good to hear it’s a focus for them this week.

Looking forward to this being possible!


#5

Hello,

I just transferred a domain to Cloudflare and enabled DNSSEC… expecting that it would work instantly :slight_smile:
It didn’t, but at least I was able to manually add the DS record (the pop-up and copy/paste worked fine).

It still says “DNSSEC is pending while we wait for the DS to be added to your registrar. This usually takes ten minutes, but can take up to an hour.” but I have no idea if it will actually work or not. I’ll keep you posted.


#6

… and just one day later: DNSSEC has been activated for my domain!

Thanks Cloudflare :slight_smile:


#7

Reached here researching the same issue. I just moved my domain to Cloudflare as the registrar.

DNSSEC page states

…If Cloudflare is your registrar, you do not need to take any additional steps and DNSSEC for your domain will be automatically enabled in the next 24 hours.

However, I can also see the button which says “Enable DNSSEC”

I am confused. Should I click on enable OR wait?

Please guide me.
Thanks.


closed #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.