DNSSEC Bug?

I removed the DS record from the current domain registrar and tried to disable DNSSEC in Cloudflare.
However, even after two days, Cloudflare still says, “Your DNSSEC setup will be disabled as soon as we detect that the DS record has been removed from your registrar.”
Strangely, when I press the “Cancel Deletion”, the “How to enable DNSSEC” window is displayed and shows the DS record to be added.
When I close this window, the button is changed to the “Cancel Setup”, and pressing this button changes to the “Cancel Deletion” again.
Is this a bug?

  • Additionally, when I lookup the DS records in my domain through DNSSEC Analyzer, it says No DS records found for My domain name in the io zone.

This seems something similar to what other people have reported (See this thread: DNSSEC stuck at pending - #8 by user11738)

Please open a ticket: support AT cloudflare DOT com and explain the situation, including a link to this thread. As soon as you get the autoreply, which will probably also auto-close the ticket, post the ticket # right here so we can escalate.

1 Like

Thanks for your reply. But how can I open a support ticket? I can’t proceed to the next step because my domain is not displayed. Is it because it’s a free account?

Update: This issue occurred while disabling DNSSEC to transfer my domain to Cloudflare. The Auth Code required for domain transfer did not work properly, so I contacted my original registrar to get a renewed Auth Code, and with this code, I succeeded in applying for domain transfer.
The DNSSEC issue isn’t resolved yet, but I’ll let you know if anything changes.

Follow this article to create a support ticket: https://support.cloudflare.com/hc/en-us/articles/200172476-Contacting-Cloudflare-Support#h_7b55d494-b84d-439b-8e60-e291a9fd3d16

I created a request #2324250.

I solved the problem! For someone who will experience the same problem, I post a solution from the support team.

curl -X DELETE "https://api.cloudflare.com/client/v4/zones/[Your Zone ID]/dnssec" \
     -H "X-Auth-Email: [Your Email Address]" \
     -H "X-Auth-Key: [Your Global API Key]" \
     -H "Content-Type: application/json"

API reference:
https://api.cloudflare.com/#dnssec-delete-dnssec-records