DNSs set correctly but website not on Cloudflare


#1

Hello there,
My wordpress website, a simple static HTML page of less than 700 kB, is hosted by Bluehost and the DNSs are correctly pointing to Cloudflare. I am not setting up Cloudflare in the cPanel as that could give problem with the SSL certificate apparently


On the DNS page, everything is “orange”. However, the website is not using the CDN according to here but it is OK on this other one!


I have created two Page rules: the 1st to redirect from the naked domain to the www-version, and the 2nd to cache everything (followed this example).

Finally, I have a SSL certificate from Cloudflare but there is no “green lock” on the browsers. Of course it is not a major problem, or at least not as much as the slow server response.

Probably it’s a simple mistake and I think there is a lot of room for improvement but I can’t figure it out how! :slightly_smiling_face:
Thanks
Gio


#2

I can’t see any issues here.

$ host -t ns giogiuliano.com
giogiuliano.com name server ivan.ns.cloudflare.com.
giogiuliano.com name server dahlia.ns.cloudflare.com.

$ nslookup giogiuliano.com
Server: 127.0.1.1
Address: 127.0.1.1#53

Non-authoritative answer:
Name: giogiuliano.com
Address: 104.24.100.52
Name: giogiuliano.com
Address: 104.24.101.52

Maybe the results at doesitusecloudflare.com are cached for some reason. :thinking:

EDIT:
checked with some other pages I know where CF is active. Same result: CF is not active.


#3

Ah well OK then, and thanks for the prompt reply :slightly_smiling_face:
I checked with a Firefox add-on (Detect Cloudflare) and that says CF is not active, probably a matter of cache?


Any suggestions on how to speed up the load time? I minimised the requests down to about 19 with Autoptimize and I would expect something faster than 2s/2.5s to load the page. Probably there is some setting to tweak in the “Page Rule” section?


#4

It looks like you’re doing a great job of using Cloudflare to cache your site. It’s loading in less than a half-second on my desktop and at Pingdom:


#5

Thanks and you’re right, the results from US cities are great and much better than the ones from Stockholm or Melbourne!
One last thing: is there any way to reduce the time gap between the various requests? Not a big deal, but just wondering how to “compress” the last requests.


#6

I would do two things:

  1. Remove the Emojis. You’re probably not using them. https://www.itsupportguides.com/knowledge-base/wordpress/wordpress-how-to-remove-wp-emoji-release-min-js-and-css/
  2. Load Google Fonts locally. Edit your .css file to remove the call to googlefonts and replace it it with local CSS font code and font files using this tool:
    https://google-webfonts-helper.herokuapp.com/fonts

#7

I followed your suggestions and there is some improvement particularly with the font loading, now from the site itself instead of requesting them from Google each time (screenshot attached). The time gap is still present but at this point I am happy with the overall results after optimisation.
Thank you for your help, and I have learned something new too.


#8

Thanks to your cache settings and having all resources local, your site is super fast!

And it’s also looking pretty good from Stockholm.


#9

This topic was automatically closed after 14 days. New replies are no longer allowed.