DNSKEY's stuck on domain, Cloudflare is registrar

Issue

I have two domains on Cloudflare:

  • environs.io
  • environs.dev

Both have the exact same CNAME entries. environs.io works properly, test site renders. environs.dev does not work. I found after investigating, the only difference is that environs.dev has two DNSKEYs attached to it. (I cannot attached a link, I just used the free DNS Lookup if you Google it)

Under the settings for the environs.dev, DNSSEC is turned off. I believe these keys are the reason the site is not rendering. How do I get rid of these keys?

Cloudflare is also the registrar.

I also tried using the API to delete DNSKEYs: https://developers.cloudflare.com/api/operations/dnssec-delete-dnssec-records

Both domains work and show the same “Hello World” site for me.

Also, the DNSKEYs will not cause any problems.

1 Like

Really?!?! Thanks, Laudian. I am still not seeing the Hello World site on environs.dev, curious if I have DNS lookup cache issues… debugging…

Yes, Solved, Laudian for the help. My current DNS Lookup was the issue. Tried on a different address and the page shows.

Btw, you should really activate DNSSEC. There is no reason not to.

3 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.