DNS Validation Error?


#1

I am trying to add a Type - A Record but it does not get added and shows a message with the following: DNS Validation Error (Code:1004) Invalid proxied mode. Record can’t be proxied (Code: 9041)

Why is this happening and how can this be be solved?


#2

Usually that should not happen with A records.
Please give a try to deleting and recreating the record.


#3

Do you know who owns the IP? Generally we do not allow you to proxy an IP of a service that forwards traffic (such as another CDN). This is partly because of performance issues, and security concerns.

If you see this error, it likely means that this target value is part of an internal list we maintain. If you create a Support ticket our team can provide you more insight here, and possibly correct a bug if this is not a non-proxyable IP.


#4

Having an error too. On validation my app says DNS server returned answer with no data…anyone know why?


#5

reloading helps, or just deleting and adding A record, and if you’re adding to another service and using cloudflare for dns, turn cloudflare’s proxying off


#6

This is for those who end up reading this thread like I did. I came across the same issue and then realised that my site was on Paused mode. Once I deactivated the Paused mode, it let me add the new A record without any issues.


#7

I just checked and my site isn’t on Pause mode.

I am having the same issue. I have the Cloudflare Nameservers under my hosting DNS and it says active on CF, but for the DNS Records I don’t have A, AAAA, MX or CNAME besides my one website (that is active).

Any idea on how to fix this when I don’t know which IP I should be using?

I’ve looked up the IP address for the new active CF website and when I try to add it it tells me I click on the cloud icon to turn it grey.