DNS Validation Error (Code: 1004) when trying to add dkim

We are getting same error every time we try to add dkim._domainkey as TXT type and dkim key to the content field.

DNS Validation Error (Code: 1004)

That’s the error. No more.

We are getting this error on multiple sites.

We never encounter such error before when adding dkim key.
What is going on?

1 Like

Can you post a screenshot of the screen where you are trying to add it? Preferably even with the error message.

All right, looks okay to me. I notice however you are on the new UI, maybe there is some glitch there. I’d suggest to open a support ticket.

1 Like

I have exactly the same error, error message says “TXT records can only contain printable ASCII”, and I’m sure my dkim record satisfies this requirement. Would be nice to post solution in public and not have everyone post own support ticket, seems to be common issue

Well, there is no solution. Cloudflare will need to fix the issue and that you can achieve for your account only with a support ticket.

However, that is assuming it is an actual issue and not an error on your side (which your error message might suggest). What value are you trying to add? I could just create a TXT record without any issues. Make sure you do not have any invisible whitespace characters in the case you are pasting the value.

Same issue here. I’ll contact support.

Here is the workaround for this:

  1. Add the TXt record with a dummy string value
  2. Click on the dummy value to open the editor
  3. Paste in the real value and save

This isn’t affected by the UI bug.

1 Like

Did you double check you did not copy an extra space in the copy/paste the new UI seems to hand out 1004’s for that a lot.

1 Like

This topic was automatically closed after 31 days. New replies are no longer allowed.