DNS Validation Error (Code: 1004) CNAME content cannot reference itself

I am trying to add my root domain CNAME record. After I type in the info I’m supposed to and hit “Add record” I get a popup that says DNS Validation Error (Code: 1004) CNAME content cannot reference itself. How do I fix this?

I haven’t seen that before, but it sure sounds like the “Name” part of the CNAME and the “Value” of where it points is the same place. Can you post a screenshot of what you’re trying to enter?

The @ is shorthand for your domain name, so if you have a CNAME for @ that points to example.com, then that means you want example.com to point to example.com

Furthermore, you already have “A” records for your root domain that point to Cloudflare IP addresses, and I suspect that’s also a problem for a handful of reasons.

What instructions are you following?

I’m following instructions from click funnels. Unfortunately I’m not tech savvy at all, but you probably already realized that.

Is there any way to fix what I must have screwed up?

When I got to this part, under ‘Type’ it did not say CNAME at all.

The instructions below look much simpler. And it looks like it doesn’t require any of those A or AAAA records, which you should get rid of if the following instructions are correct. You can click those records which will bring up an editor with a Delete link.

So I was able to figure out what I was doing wrong, thank you so much for your help. I’m following the instructions you sent me. I did steps 1 & 2. Now I’m to step 3 but am stuck again. It’s telling me to click Page Rules at the top navigation. But my screen isn’t showing a too navigation.

That looks like the screen you get when you first add a site. What happens when you click Continue?

image0.jpeg

I don’t know how you got to this point, but it looks like you’ve completely reset your domain, including resetting the name servers at your registrar. You need to finish the setup process for that domain by following those instructions to Change Your Nameservers, etc.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.