DNS updates (Agile CRM, Microsoft Office - 24 hours later still not working)

Hi,

I’ve been using Cloudflare for a few years and it’s worked great.
I use AgileCRM for newsletters and Microsoft Office 365 for mail.

I was hoping someone could look over this to send some insight into why updates to my DNS (24+ hours later) still haven’t taken effect please?

Recently AgileCRM said “Please configure DKIM and SPF settings to send campaign emails”, so I added
MX agle mx.sendgrid.net.
TXT agle v=spf1 include:sendgrid.net ~all
TXT m1._domainkey.mydomain.com (lots of characters)
I’ve saved it and can clearly see it as saved
TTL on all I’ve tried as Auto and Also 5min.
Proxy status is DNS only for all
I already had MX and TXT records for outlook.com.

I’ve been checking whatsmydns .net and other sites constantly and the new AgileCRM MX & TXT records still aren’t showing there.
I contacted AgileCRM and they say your DNS provider may take 24 hours to verify them.

Is there anything else I might need to do to get the DNS changes to take effect?
It’s been over 24 hours.

(Previously other DNS updates in Cloudflare, and on other Cloudflare accounts which don’t have Microsoft, have made the changes instantly so I’m pretty worried I’ve done something wrong).

Thanks so much for reading :slight_smile:

And if you mention the domain someone could even check it out :wink:

You have set that for “agle” and that’s where it resolves

nslookup -type=mx agle.corebb.com.au darwin.ns.cloudflare.com
Server:  darwin.ns.cloudflare.com
Address:  172.64.33.151

agle.corebb.com.au      MX preference = 1, mail exchanger = mx.sendgrid.net

But I presume that’s not what you want (or did you mean to configure addresses for @agle.corebb.com.au), right?

You’d need to fix these two records and point them to the right address and most likely remove the other records, otherwise you have your MX records point to two different services.

You probably need to clarify with them what exactly you need to set up.

Right now you can receive emails under @agle.corebb.com.au and they will go to the specified server. If that’s what you need, then you are set. If not, you need to clarify the requirements with them.

Same goes for the TXT record, but the domainkey one will probably need some adjustment.

They should give you exact instructions on what records they expect and with which values.

Plus, your @corebb.com.au emails currently go to Microsoft or reflexion.net too. Not sure that’s what you intended either.

It’s not showing up as updated in any of my DNS checkers which I’m stumped about.
Thanks for your help! I really appreciate it @sandro :smiley:

According to that they want that on agle.corebb.com.au and that’s what you configured, so you should be good to go.

It does, DNS Checker - DNS Check Propagation Tool

Thank you! :see_no_evil: I kept just using the domain not agle before it.
Thanks :slight_smile:

Yep, right now your emails can go to two different services and I guess that’s not really the idea.

If you only use Microsoft you probably should remove the other MX record, but you best double check.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.