DNS updated but emails not working

Hi looking for some assistance i know the weekend things have been down. However when i update my DNS back to cloudflare i am not getting incoming emails. I am able to send but not recieve. Is this still a issue?

Is the R2 bucket system also still got issues

Hey Janik please can you help me. I know that the system webt down, but i have been struggling to get my emails to work again. The DNS propogation eventually came back ane i managed to get that sorted over the weekend. However i still have R2 bucket issues and emails. When i activate cloudflare on my site i get email delivery issues, can send emails, but cannot recieve emails. Some help would be appreciated as we run a web and hosting company. Thank you


What’s your domain name?

Having issues to with updating the DNS then things go back to cloudflare but emails are sent but not been recieved. I have had to go back to the original name servers and its been like this the entire weekend. I know that things were offline but how can we tell whats working and what is still off ?


my dns is currently set to my server name servers as I was having endless issues with cloudflare over the weekend. I finally got the DNS to update but like I say the emails were sending but not receiving. Thanks for looking into things

Sorry about the issues you’re experiencing!

Your MX record is pointing to “mail.timswebworx.co.za” on both Cloudflare and your current provider.

$ dig +short timswebworx.co.za. MX @casey.ns.cloudflare.com    
10 mail.timswebworx.co.za.
$ dig +short timswebworx.co.za. MX @ns105.my-control-panel.com 
10 mail.timswebworx.co.za.

However, your Cloudflare zone doesn’t have an A record for the “mail” subdomain.

$ dig +short mail.timswebworx.co.za. A @ns105.my-control-panel.com 
$ dig +short mail.timswebworx.co.za. A @casey.ns.cloudflare.com   
(no output)

To fix your email delivery, create an A record named “mail”, pointing to that IP address, on your Cloudflare zone.

Hope that helps! I’d suggest opening a separate topic (or contacting support) about the R2 issue you’re experiencing. Please include as much information as possible.

Thank you for being so fast and helpful. So I can update back to Cloudflare and add that missing record and it should work now ?

Happy to help! I’d suggest adding the “mail” record first and only then moving your nameservers back to Cloudflare.

Before you switch your nameservers back, you can use my commands from above to ensure your A record was created correctly:

$ dig +short mail.timswebworx.co.za. A @ns105.my-control-panel.com
$ dig +short mail.timswebworx.co.za. A @casey.ns.cloudflare.com
198.xxx.xx.x (should be the same as above!)

Alternatively, you can also use nslookup on Windows or one of the various sites available online for looking up DNS records. Just make sure you use DNS server “casey.ns.cloudflare.com” for the second query instead of the default (which would go to your current provider, since that’s where your NS is currently pointing to).

1 Like

Still having issues added the mail record updated the NS servers to cloudflare but then on checking it shows some locations updating to cloudflare NS but the A record remains my server IP and does not update to cloudflares IP??

Here is the other image

This has been happening to me all weekend update nameservers but it stays on my server IP. Its like its not changing over. And then I get constant errors and issues.

Hi, everything looks as expected.

  1. Your A record on “mail” is now set up correctly on Cloudflare.
  2. Your zone apex isn’t returning Cloudflare IP addresses because it’s not orange-clouded (proxied). To enable Cloudflare for your web traffic, you need to proxy the A record (or CNAME) at the zone apex. (Just make sure you don’t proxy your “mail” subdomain.)

Hi everything is set up as it should be and yet all my emails are still not working. The moment I turn on the proxy my emails stop working. This is a problem as we run freshdesk and WHMCS and need the emails to work.

Your help is truly appreciated as we need to get this fixed asap

You need to proxy the address (A, AAAA and/or flattened CNAME) record(s) at the zone apex that you want to use for your website. Do not proxy the “mail” record.

Can i show you what is happening with the records so you can see?

here is a screencast - so i turned the A record to proxy and enabled cloudflare over night and I am still not getting any emails to my inboxes. You can see then I turn off cloudflare to see if things would work and I still don’t get emails. I have tried to take a video of the DNS records and also on my hosting panel.

Im trying to share a video link but it wont let me ??

[Preformatted text](https://share.vidyard.com/watch/HYTwNfBoc1rHXZzx65TPbo)

Seems i found the error :frowning: the hosting has removed all my email accounts when they thought there was a issue ---- gosh an i only noticed it now. Sorry i am sure once i add them all back things will work.

some bright spark removed all the email addresses :frowning: