DNS still routing to old website for some people

My google domain used to point to a wordpress site. I’ve gotten it to switch to my Kajabi site for www.leichtninghealth.com and https://www.leichtninghealth.com but leichtninghealth.com is still going to my old site (which is just an error message). Any tips?

Here’s my DNS setup.

Your rootDomain leichtninghealth.com does not have any public A/AAAA record.
Please add them to make your rootDomain work properly

For doing so set up a CNAME like this:

TYPE NAME CONTENT
CNAME @ endpoint.mykajabi.com

@ stands for leichtninghealth.com

After this I anyway would redirect leichtninghealth.com to www.leichtninghealth.com to in the end just use one Domain and not produce duplicated content.

1 Like

Thank you! Does it matter what the TTL and proxy status are when I add the new CNAME? Also do I need to delete anything?

Does this look right now?

Just set it to Auto, CloudFlare will then set the TTL automatically to fit your needs the best.

I personally would definitely proxy ALL requests that are possible. So I also would change the WWW entry to Proxy :orange:. Then your site will benefit from all CloudFlare benefits. If not proxied :grey: CloudFlare will not speed up your site, but just functioing as a DNS service only.

No you do not have to delete anything.

Yes it should work as soon as the DNS entry is propagated! (can take some hours)
Additionally I like I said would even turn on proxy at the WWW subdomain.

But the CNAME _domainconnect I would not proxy. Just proxy everything related to WEB. Nothing else :slight_smile:

1 Like

You’re a life saver. It’s already working. Thanks!

Sam

1 Like

Let me quickly revise one thing I said and make sure you will not encounter any problems soon.

This often makes sense, but seems not to be the case with Kajabi!
I just had a read at their Docs and they recommend NOT to proxy the CNAMEs.

See:

So please turn off the Proxy :orange: and use CloudFlare with Kajabi in DNS only :grey: mode.
This docsumentation site is btw a good help to configurate the rest of the CLoudFlare settings. If you scroll down you will see many more help at what SSL mode to chose and what PageRules to set up

Hm but lower down (at troubleshooting)

They provided a Screenshot where they again used Proxy :orange: mode.


May on this one they should be really clear on what not! So maybe it works with :orange: aswell but is at least not recommended officially…

Dont like that they are not very clear on that.

So this is actually what it should look like?

Yes thats it!
It might also work when proxied (:orange:) but as the official docs state not to do its better to not proxy it.

Their support might can enlighten us on whether it is just not recommended or if it does not work when proxied as I would always try to proxy WebTraffic if possible as then you are benefiting from all the good CloudFlare things :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.