DNS settings to use when using UK Cheapest for hosting **FIXED**


#1

Hi

I’ve tried a few different things, all result in https showing on my site but no incoming emails OR incoming emails but no https. I can’t seem to get both working together.

Can anyone that uses Uk Cheapest hosting show me a screen shot of their fonfiguration?

I’ve tried looking up answers other people get with other hosters but no answer there, looking bit different.

Thanks


#2

My guess is that you’ve set your MX record to :orange: and deactivated CloudFlare on both records with the result that HTTPS doesn’t work but email does.

CloudFlare does not proxy email traffic.


#3

I found the solution.

Actually, the MX record is a record that does now give the option to toggle cloud orange or grey as there is no cloud icon there on my screen, and other people’s screenshots I’ve seen.

What I was doing was toggling one of the A records off and on (orange and grey), this was giving me either emails working but no https OR https showing but no incoming emails.

My fix was to turn all the A records into a grey cloud then go edit my DNS records on my hosting account with UK cheapest as I noticed something wrong.

I had previously changed the nameservers the domain points to in domain management but the DNS records were giving NS as microlite so I chaned NS1 and NS2 to those given by Cloudflare.

I also realised I had better turn the cname record for ftp into grey cloud so I could use my FileZilla for ftp access :slight_smile:

Thanks for reply


#4

Glad to hear :slight_smile:

Little hint regarding FTP, SSH and so on: Cloudflare only supports the foklowing ports at the moment if your records are set to :orange:

For requests made via HTTP:

80
8080
8880
2052
2082
2086
2095

For requests made via HTTPS:

443
2053
2083
2087
2096
8443


#5

Cheers!


#6

Oh well

It appears I spoke too soon. A little while later the https:// broke! I still can’t work out how to get email working and https:// to show.

There is one cloud that if I toggle it orange https:// works but problem with emails then when I toggle the cloud grey email works but problem with the htpps://.

Here is my configuration, would you happen to know what the problem might be from looking at it? 0.00.00.000 = my host IP and domain = my website

It’s the A record with Name: domain that I have been toggling grey and orange with grey giving emails of and problem with https:// and orange giving https:// ok but problem with emails.

All of these records were auto created by cloudflare apart from the ipv4 which I added to see if that would sort things.

Type: A Name: ipv4 Value: points to 0.00.00.000 TTL: Auto - Grey Cloud

Type: A Name: mail Value: points to 0.00.00.000 TTL: Auto - Grey Cloud

Type: A Name: domain Value: points to 0.00.00.000 TTL: Auto - Orange Cloud

Type: A Name: webmail Value: points to 0.00.00.000 TTL: Auto - Grey Cloud

Type: CNAME Name: ftp Value: is an alias of mail.domain TTL: Auto - Grey Cloud

Type: CNAME Name: www Value: is an alias of mail.domain TTL: Auto - Orange Cloud

Type: MX Name: domain Value: mail handled by mail.domain (10) TTL: Auto - No Cloud

Type: TXT Name: domain Value: v=spf1 a mx ip4:0.0.000 ip4:0.00.00.001 mx:mail.ukc04.uk mx:ukc04.uk ~all TTL: Auto - No Cloud


#8

DOH! I eventually fixed it by changing my settings in outlook, I had mail servers, both incoming and outgoing set as mydomain and changing them both to mail.mydomain sorted the email issue I was having when switiching my A record to orange cloud :slight_smile:


#9

This topic was automatically closed after 14 days. New replies are no longer allowed.