DNS Settings - Email with Subdomain

Dear Cloudflare Community,

my domain is smanique.com, I created a subdomain and called it e.smanique.com to be dedicated to email marketing. I can send and receive emails both in RoundCube and Prestashop with the email [email protected] while with the email [email protected] I can send and receive emails through RoundCube but not through Prestashop. I get the error:

Connection could not be established with host e.smanique.com [connection timed out # 110]

I am attaching the screenshots of my DNS settings. Could you give me a hand to understand what am I wrong?

Thank you in advance.



Schermata 2021-08-31 alle 17.48.40

Any hostname used for email connections (SMTP/IMAP/POP) needs to be set to :grey: DNS Only. In this case, your e hostname is set to :orange: and is causing the problem.

Looking at some of your CNAMEs, they may be :grey:, but still point to a hostname that’s set to :orange:. That’s not good.

1 Like

Thanks for the advice. I set the hostame e to :grey:

Now I can send emails through Prestashop but the email comes from [email protected] instead of [email protected].

Regarding the second point you specified:

Looking at some of your CNAMEs, they may be :grey:, but still point to a hostname that’s set to :orange:. That’s not good.

I should also set the following records to :grey:?


Thank you.

The rule of thumb is that Email connections (MX/IMAP/POP/SMTP) should not be hostnames used for a website. That’s why it’s best to use a ‘mail’ subdomain.

If ‘e’ is not a website, that it’s only used for email, then you can leave it be, but make sure it’s :grey: DNS Only.

That’s something you have to configure in your software. Either the return address, or which connection you use for sending email. That’s not influenced by Cloudflare settings.

1 Like

Yes e is only used for emails so I leave it as you suggested. Also I figured out where to change the “from” field on my software. Thank you so much!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.