DNS Servers Changed, but still not recognized by Cloudflare


I have the domain tl-photography.at.
I changed the NS records and could verify this here: https://dnschecker.org/ns-lookup.php?query=tl-photography.at&dns=google

But Cloudflare still can’t verify my domain.

Any ideas what I could do?

PS. I change the NS records on the weekend, so plenty of time to propagate.

Welcome to the Cloudflare Community. :logodrop:

% whois tl-photography.at
domain:         tl-photography.at
registrar:      T-Mobile Austria GmbH ( https://nic.at/registrar/60 )
registrant:     <data not disclosed>
tech-c:         UAG8317792-NICAT
nserver:        ns1.nameservice.at
nserver:        ns2.nameservice.at
changed:        20210325 00:14:11
source:         AT-DOM

You appear to have created NS records in your DNS zone at ns1.nameservice.at and ns2.nameservice.at. That is not how you add a domain to Cloudflare.

You need to replace the ns1.nameservice.at and ns2.nameservice.at nameservers at your registrar with those assigned by Cloudflare, presumably ada.ns.cloudflare.com and roan.ns.cloudflare.com, but best to copy and paste from your Cloudflare dashboard. https://dash.cloudflare.com/?to=/:account/:zone/dns/records

See item 2 in the following Community Tutorial.

1 Like

I have changed the NS entires at my registrars DNS settings.

How can it be that whois on CMD shows the old entries, while https://dnschecker.org/ns-lookup.php?query=tl-photography.at&dns=google shows the entries I have got from CF?

You are changing the NS records in your zone, tl-photography.at.

When you update the nameservers at your registrar as required, the nsameservers for tl-photography.at. are updated in the parent nameservers for the at. zone.

Let’s ask the internet for the NS records for at. and ask one of them for the nameservers for tl-photography.at. to help you understand why what you are doing is not working.

% dig ns at. +short                  
dig @j.ns.at. ns tl-photography.at.       

; <<>> DiG 9.16.42 <<>> @j.ns.at. ns tl-photography.at.
; (2 servers found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 45494
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 2, ADDITIONAL: 5
;; WARNING: recursion requested but not available

; EDNS: version: 0, flags:; udp: 1232
; COOKIE: 7adb3f10158554740100000064cac5b56f7fdef4453df151 (good)
;tl-photography.at.             IN      NS

tl-photography.at.      10800   IN      NS      ns2.nameservice.at.
tl-photography.at.      10800   IN      NS      ns1.nameservice.at.

ns2.nameservice.at.     10800   IN      AAAA    2a02:8383:d:200a::1
ns1.nameservice.at.     10800   IN      AAAA    2001:4bc8:2000:702::1
ns2.nameservice.at.     10800   IN      A
ns1.nameservice.at.     10800   IN      A

https://dnsviz.net/d/tl-photography.at/dnssec/ gives me two warnings:

at to tl-photography.at: The following NS name(s) were found in the authoritative NS RRset, but not in the delegation NS RRset (i.e., in the at zone): roan.ns.cloudflare.com, ada.ns.cloudflare.com
at to tl-photography.at: The following NS name(s) were found in the delegation NS RRset (i.e., in the at zone), but not in the authoritative NS RRset: ns1.nameservice.at, ns2.nameservice.at

but I guess that’s normal?

So the DNS NS I changed is not that what I need to change, I guess?

Hmm ok, but I have no idea how to ask them as to send ‘them’ a mail and I don’t even know where to send it to.

Seems not cloudflare for me then :woman_shrugging:

No, it is not normal. It is a symptom of changing the NS records in your current DNS provider instead of changing the nameservers at your registrar.

Correct. You need to change the nameservers in your whois record at your registrar.

Vielleicht hier:

Ok thanks!

Yeah that’s the provider I have, but there is no option for that, expect of what I did earlier.

I’ll write them, let’s see.

But, thanks again!

1 Like

I finally found where I can change it, ‘hidden’ in plain sight. :roll_eyes:

Let’s see, I have requested a new check.

If anyone is using Magenta as their provider, use the option “Domainverwaltung” directly in Plesk, instead of the DNS settings.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.