DNS rules not resolving

My MX dns configurations are not resolved, I haven’t changed anything for the last year and everything has worked fine, suddenly MX records are no longer resolving. I tried deleting the records and putting them back. Still doesn’t work. My domain is theteamcoders.com and no DNS rules are resolved what so ever.

It is fatal that I get these to resolve again.

It sure looks like there are no DNS records. Make sure that DNS page you’re using shows Cloudflare’s name servers as ivan and cloe.

Can you post a screenshot of the DNS page? It’s ok if you block out IP addresses.

I just realised my domain is not managed by cloudflare anymore. I’ll look into that.

1 Like

It looks like something must have gone wrong with the domain transfer to cloudflare, I am no longer in control of my domain. Any ideas on how I can regain it?

1 Like

After researching the current status of the domain it seems the domain is managed by Verisign (verisign-1666). I am not in control of my domain. The domain’s status is clientHold and clientTransferProhibited. I’m unable to do anything until the morning. I’ll call my registrar and let them know of the issue and present proof of ownership. The domain is currently without any owner(s).

Verisign owns the .COM registry. It looks like Freenom is in charge of your domain at this point.