DNS resolves to invalid domain

I have some RSS feeds on my site that are not resolving correctly.

I checked with the hosting provider and they said that requests for the RSS feed urls are not arriving to their servers, instead terminating inside Cloudflare.

I have removed all worker routes previously configured on the domain, so as far as I can see, only DNS configuration remains.

For the rss files, the domain gets replaced by an invalid domain. The rest of the site resolved correctly.

Your forum system won’t allow me to post links so I can’t give you an example.

Why is this happening? How can I fix it?

You can use the Preformatted text option in the formatting menu to share domains and URLs without them being turned into links.

The feeds can all be found

markjgsmith dot com / feeds

Notice that any feed from that page you try to open in a browser, have the domain replaced by an invalid domain. It’s doing something like taking the first folder name and turning it into a subdomain.

I tried adding the URLs using the format menu but it always shows an error popup which says to use backticks, which I also tried and also does not work.

What is causing this invalid domain replacement?


Feeds are here:


For example:


Resolves to invalid url:


This is a redirect you configured on Cloudflare. Check all the rules you configured, you will have something of that sort


If it’s a page rule, you are probably missing an asterisk in front of the hostname. You simply used the wrong capture group.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.