DNS resolve problem with 1.1.1.1 and 1.0.0.1 at least for weather.gc.ca and meteo.gc.ca

I have problems resolving certain domains with 1.1.1.1 and 1.0.0.1 at least for weather.gc.ca and meteo.gc.ca. Anybody have this same behaviour ? The status page show everything is Operational and my support request was dropped because I don’t own the domain…

Test with google dns:

$ dig @8.8.8.8 meteo.gc.ca +short
205.189.10.44
205.189.10.43

Test with google dns:

$ dig @8.8.8.8 weather.gc.ca +short
205.189.10.43
205.189.10.44

Cloudflare DNS:

$ dig @1.1.1.1 meteo.gc.ca +short
$ dig @1.0.0.1 meteo.gc.ca +short
$ dig @1.0.0.1 weather.gc.ca +short
$ dig @1.1.1.1 weather.gc.ca +short

Test with Quad9 dns

$ dig @9.9.9.9 weather.gc.ca +short
205.189.10.43
205.189.10.44

Test with opendns home:

$ dig @208.67.222.222 weather.gc.ca +short
205.189.10.44
205.189.10.43
$ traceroute 1.1.1.1
traceroute to 1.1.1.1 (1.1.1.1), 30 hops max, 60 byte packets
1 HIDDENHIDDENHIDDENHIDDEN (HIDDENIP) 0.246 ms 0.378 ms 0.460 ms
2 HIDDENHIDDENHIDDENHIDDEN (HIDDENIP) 16.774 ms 18.880 ms 18.898 ms
3 10.170.158.194 (10.170.158.194) 20.855 ms 20.896 ms 21.043 ms
4 216.113.123.170 (216.113.123.170) 20.923 ms 21.077 ms 20.950 ms
5 216.113.125.81 (216.113.125.81) 21.090 ms 21.156 ms 21.470 ms
6 one.one.one.one (1.1.1.1) 19.528 ms 16.506 ms 17.398 ms
$ dig @1.1.1.1 weather.gc.ca

; <<>> DiG 9.16.1-Ubuntu <<>> @1.1.1.1 weather.gc.ca
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 11712
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
; OPT=15: 00 16 ("..")
;; QUESTION SECTION:
;weather.gc.ca. IN A

;; Query time: 16 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Tue Oct 05 11:50:05 EDT 2021
;; MSG SIZE rcvd: 48