DNS Resolve - OpenVPN

Hello fellow geeks!

I have an issue:

I have a no-ip registered FQDN I’m used to using with my OpenVPN VPN configured in pfSense. (It works using my pub IP)

I have migrated DNS to clouldflare, and am running into a snag resolving my FQDN (rosenstrong,com) through my OpenVPN client. - Unable to resolve (authoritative)

I have disabled proxy.
I have my Cloudflare DNS servers configured on my Registrars admin page.
Whois is showing me my cliudflare DNS server (mxtoolbox)

I have tried overriding client DNS settings and everything on the OpenVPN side. - nada.

Please help? :pray:

rosenstrong.com resolves ok for me and you are set up correctly with Cloudflare as far as I can see.

What DNS server is the OpenVPN client using? The issue would appear to stem from there.

2 Likes

Thanks for your reply!

In my OpenVPN server configured using the pfsense wizard, I have tried setting override DNS, and leaving client DNS to the client.

pfSense set to 1.1.1.1

  • I do have force all traffic through the tunnel which shouldnt affect it.
1 Like


Here is a screenshot of my current dns settings

Made me take a closer look at my VPN settings, and after adding vpn,rosenstrong,com as depicted it worked.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.