DNS resolve error

Hello, my name is Albert and I just joined Cloudflare resently.

Last week I have transfered my domain (networkberries.net) to Cloudflare.
The other provider has been cancelled.

I have created the following DNS records:
A: @ → public IP address (My public IP address)
CNAME: www. → @
Name servers are those of Cloudflare.

When I go to the URL and enter the domain it will not resolve.
When I enter public IP address there is no issue and I can see a login in screen.

I have performed a DNS lookup and I noticed it is pointing to another IP (Cloudflare)
A: networkberries.net IPv4 Address: [172.67.136.111]
A: networkberries.net IPv4 Address: [104.21.7.148]

Did I made a mistake in the DNS records (which shows my public IP) and how can I solve this.

Thank you for your time and support.

Greetings! Welcome to Cloudflare Community :slight_smile:

Thank you for asking.

No, you did not. Everything is fine.
You would see Cloudflare IP on the lookup when the DNS records are proxied and set to :orange:
Therefore, sometimes you get the IPs from the same subnet network like both starting with 104., sometimes different like one from 172 and other from 104, or even nowadays both from 108, etc. It’s all Cloudflare, and it is working as expected.
That’s the Cloudflare’s anycast network “behind the scenes” :wink:
You’ve done everything correctly :slight_smile:

Regarding this, I get 522 error when I try to access your Website:

Regarding Cloudflare 522 error, may I suggest you to try looking into below articles to troubleshoot the issue:

Before moving to Cloudflare, was your Website working over HTTPS connection?

You could determine this by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
  4. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

Furthermore, do not skip below step and kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

Thank you for your valuable feedback.
I was reading all the interesting articles and I noticed that I still have a long way to go.

Update: Cloudflare proxy is not compatible with all ports.
I was making port forwardings and nothing worked, until I came accross an article
https://developers.cloudflare.com/fundamentals/get-started/network-ports

Once again I have a lot to understand :slight_smile:

After many tries I found out the cause of the issue.
When disabling the proxy (which is enabled standard) I could resolve my domain.
I am not clear how this works and maybe it is mentioned in one of the articles.

Once again for your effort.

Best regards,
Albert

Thank you for feedback.

Can you change the port which your app is using to the one which is on the list of supported and compatible ones with Cloudflare proxy mode :orange: ? :thinking:

Or by that way, but use the one port which is supported and compatible on the external side.

Otherwise, you can switch your DNS record (hostname) to :grey: (DNS-only) and it would work.

There is a feature called Cloudflare Spectrum, but it costs and requires higher paid plans to use more ports than usually supported. If interested, please check the link from below:

Official product webpage:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.