DNS Records - Website not working with Orange Cloud enabled

#1

Greetings Cloudflare community!

I recently just used Cloudfare for my static website with a bit of php hosted on a VPS, I’m not sure if I have set it all up correctly.

Because, once I turned on the :orange: orange cloud on the DNS records my website would stop loading correctly. So I had to switch it back to the :grey: grey cloud. I already tried looking up for existing threads on the community but I can’t see any fixes.

P.S. > I have an :cert: Let’s Encrypt SSL configured on my VPS and have tweaked the SSL setting on the Crypto tab to “Full (strict)”.

0 Likes

#2

What is your domain and what is the loading issue?

0 Likes

#3

futuregadgetlab.com.ph

:orange: ERR_SPDY_PROTOCOL_ERROR
:grey: Website normally loads

1 Like

#4

This thread might help explain it…

If not, I am probably not the best person to, but I am sure someone else can!

1 Like

#5

I seem to have found what my problem is, I think this is HTTP/2’s doing.
I am on a free plan and I can’t seem to disable this.

Edit*: Is there a way to serve my website on HTTP/2. It’s currently only being served on HTTP/1.1

0 Likes

#6

I have solved the problem myself.

It appears to I have mistakenly configured my ssl.conf’s “add_header”.
I have written it in multiple lines wherein I should have just wrote the stuff I need in a single line.

===========================================
#ssl-nginx.conf

add_header “XXXXXXXX
XXXXXXXXX
XXXXXXXXX”; // Do not do this, rookie mistake.

add_header “XXXXXXXX XXXXXXXX XXXXXXXX”; // Correct

===========================================

0 Likes