DNS records not updating on nameserver

Hi,

I had orange-cloud A records for domain cdn-staging.kamaitachi.xyz until recently. I tried changing this record to dns only as I wanted to debug some concerns I had relating to caching on my origin server. After 20-30 minutes of the nameservers still responding with Cloudflare IPs I tried deleting the record entirely. It has now been another 20-30 minutes and the nameservers are still responding with Cloudflare IPs (104. and 172.). I am at a loss.

Are the nameservers on your DNS dashboard Jose and Melissa?

% dig +short ns kamaitachi.xyz
jose.ns.cloudflare.com.
melissa.ns.cloudflare.com.

Are you on a partner setup, or is your domain in your own Cloudflare account?

Yes, they are. The domain is in my own account.

Hitting ‘Pause Cloudflare on Site’ and then re-enabling it fixed this problem. Not quite sure what happened, but I guess turning it off and on again is truly a tried and tested solution to all problems.

That might be the fix. Every time you make a DNS change here, Cloudflare regenerates the zone file. Sometimes that doesn’t happen, or has a momentary glitch.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.