DNS records not resolving after 3 days

CNAME: app (app.msgsndr.com) is not resolving after 3 days

Hi there,

I’ve just some quick check’s and DNS looks to be resolving for me although resolving to an IP address, although not proxied through Cloudflare.

msgsndr.com.		172800	IN	NS	noah.ns.cloudflare.com.
msgsndr.com.		172800	IN	NS	megan.ns.cloudflare.com.
;; Received 361 bytes from 192.42.93.30#53(g.gtld-servers.net) in 63 ms

app.msgsndr.com.	300	IN	A	35.202.49.152
;; Received 60 bytes from 2803:f800:50::6ca2:c185#53(noah.ns.cloudflare.com) in 26 ms

If you are using CNAME flattening (flatten all records) on Cloudflare this would be flattening your CNAME to an A record and need to run an A record lookup, instead of a CNAME.

You can find CNAME flattening under the DNS tab > Settings section. You can read more about it here - CNAME flattening · Cloudflare DNS docs

Seems to resolve OK…

dig +short app.amplifycrm.com @1.1.1.1
app.msgsndr.com.
35.202.49.152

dig +short app.amplifycrm.com @8.8.8.8
app.msgsndr.com.
35.202.49.152
1 Like

Looks like this is resolved now, and is resolving and following the CNAME chain?

1 Like

The CNAME is not proxied (probably as it needs to be) so requests go direct to that site and not through Cloudflare; any SSL certificate or redirect for app.amplifycrm.com needs to be set up with that service. Likely it is not configured to accept requests for app.amplifycrm.com.

What actions need to be taken? Thank you.

Hi,

You need to change proxy status to proxied if you want Cloudflare to be proxying the request and presenting our Universal SSL certificates at the edge to serve the site over HTTPS.

But keep in mind when you proxy a DNS record we convert the CNAME to an A Record and returns Cloudflare IP’s - so if you are testing DNS resolution you would need to do an A record lookup on the hostname, not a CNAME.

regards,

No, “Always use HTTPS” will have no effect if the record is set to “DNS only” since the request isn’t going through Cloudflare.

As I said, if the record is “DNS only”, any SSL settings or support for the hostname will need to be set on the service you are pointing to. Cloudflare is only providing DNS in this case and cannot do anything with the request.

2 Likes

So the issue was SSL setting on app.msgsndr.com (where we are pointing). Is that correct?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.