DNS Records not propagation - but MX and TXT records working


DNS Records not propagation - but MX and TXT records working

my domain is mapped to google sites for website, mx records for Microsoft 365. But the when I look for DNS records propagation it is not showing the C NAME, A records. Why? How to fix it?

I tried DNS> Settings > C NAME Flatten which is showing as “Flatten CNAME at Apex” no other option is shown there.

  1. What domain?

  2. Can you share a list, perhaps a screenshot, of the record(s) you have issues with, so we can see how they appear in your Cloudflare Dashboard?

  3. How exactly did you test it, or otherwise end up on that conclusion, that the record(s) do not propagate?

1 Like

Domain Name - futuredynamics.in

Is this issue created due to google sites?

DNS Checker Link -

They appear to resolve just fine. You are looking up the individual records correct?

1 Like


Link - [DNS Checker]




when we check for CNAME propagation in the above link, we get error message as “Search Error or CNAME Records not Exists. No CNAME record were found for the domain.”

Other domains are working fine.

The subdomain https://portal.futuredynamics.in is not loading the link

(https://my-planner.in )

Proxied :orange: CNAMEs are published as A and AAAA records. If you need a CNAME to be published you must set it to :grey: DNS Only.


DNS Checker Link [CNAME Lookup - Check the CNAME Record for Any Domain (dnschecker.org)](https://dnschecker.org/cname-lookup.php?query=futuredynamics.in&dns=cloudflare)

As long as your CNAMEs are :orange: you will not find any CNAMEs with any tools. They are published as A and AAAA records using Cloudflare proxy IPs.


I think there’s a misunderstanding as to how to look up a DNS record and how Cloudflare works.

First the link you are using is looking for a specific address. https://dnschecker.org/cname-lookup.php?query=futuredynamics.in&dns=cloudflare is looking for a CNAME record for the root record. Ignoring the fact you can’t have a CNAME for a root record, it’s not looking for portal.futuredynamics.in and whether it is proxied (as it currently is and will onyl return an A record or it is set to :grey: as @epic.network indicates if you really want a CNAME record is irrelavent.

DNS is working just fine…you’re simply asking for the wrong record futuredynamics.in <> portal.futuredynamics.in `https://portal.futuredynamics.in’ returns a 200 response and a blank page. If it’s supposed to return something else… that’s not a DNS issue.

dig portal.futuredynamics.in

; <<>> DiG 9.10.6 <<>> portal.futuredynamics.in
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 55604
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 1232
;portal.futuredynamics.in.	IN	A

portal.futuredynamics.in. 300	IN	A
portal.futuredynamics.in. 300	IN	A

;; Query time: 59 msec
;; WHEN: Tue Oct 17 15:09:08 EDT 2023
;; MSG SIZE  rcvd: 85

Again expected if the record is proxied… and it is.

curl -Ikv https://portal.futuredynamics.in
*   Trying
* Connected to portal.futuredynamics.in ( port 443 (#0)
* ALPN: offers h2,http/1.1
* (304) (OUT), TLS handshake, Client hello (1):
* (304) (IN), TLS handshake, Server hello (2):
* (304) (IN), TLS handshake, Unknown (8):
* (304) (IN), TLS handshake, Certificate (11):
* (304) (IN), TLS handshake, CERT verify (15):
* (304) (IN), TLS handshake, Finished (20):
* (304) (OUT), TLS handshake, Finished (20):
* SSL connection using TLSv1.3 / AEAD-CHACHA20-POLY1305-SHA256
* ALPN: server accepted h2
* Server certificate:
*  subject: CN=futuredynamics.in
*  start date: Aug 20 03:34:49 2023 GMT
*  expire date: Nov 18 03:34:48 2023 GMT
*  issuer: C=US; O=Let's Encrypt; CN=E1
*  SSL certificate verify ok.
* using HTTP/2
* h2 [:method: HEAD]
* h2 [:scheme: https]
* h2 [:authority: portal.futuredynamics.in]
* h2 [:path: /]
* h2 [user-agent: curl/8.1.2]
* h2 [accept: */*]
* Using Stream ID: 1 (easy handle 0x14c80ac00)
> Host: portal.futuredynamics.in
> User-Agent: curl/8.1.2
> Accept: */*
< HTTP/2 200
HTTP/2 200
< date: Tue, 17 Oct 2023 19:13:51 GMT
date: Tue, 17 Oct 2023 19:13:51 GMT
< content-type: text/html
content-type: text/html
< last-modified: Mon, 11 Nov 2019 07:24:47 GMT
last-modified: Mon, 11 Nov 2019 07:24:47 GMT
< vary: Accept-Encoding
vary: Accept-Encoding
< cf-cache-status: DYNAMIC
cf-cache-status: DYNAMIC
< report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=Q%2BR1bXEEprpzoEyap3od%2Bz1kmbQnggcp%2BJmW2zZT5W4wZHBg4xCSPUWofDAqQKzLNusRVNPOIajUMPa8g5xeJcJUh2%2Bkl9tbv4Q%2BTkU9joCoCkuEAuyzgSTa4IPLi8GMHdp1kY%2FbGyDhkxA%3D"}],"group":"cf-nel","max_age":604800}
report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=Q%2BR1bXEEprpzoEyap3od%2Bz1kmbQnggcp%2BJmW2zZT5W4wZHBg4xCSPUWofDAqQKzLNusRVNPOIajUMPa8g5xeJcJUh2%2Bkl9tbv4Q%2BTkU9joCoCkuEAuyzgSTa4IPLi8GMHdp1kY%2FbGyDhkxA%3D"}],"group":"cf-nel","max_age":604800}
< nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
< server: cloudflare
server: cloudflare
< cf-ray: 817adc72bee532fc-EWR
cf-ray: 817adc72bee532fc-EWR
< alt-svc: h3=":443"; ma=86400
alt-svc: h3=":443"; ma=86400

If you want it to return a CNAME and not be proxied set the record to DNS only.



I tried both
and also


The CNAMEs are not propagating.

Correct. You have configured them not to.


Thanks, learnt new thing today, that the CName cannot be checked for root domain. Took time for me to understand what root domain is. Thanks for your reply.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.