Dns records for api.bulbool.online

The NS records of the api.bulbool.online subdomain of my bulbool.online domain are not assigned. The subdomain was registered in the DNS records of the bulbool.online domain

api.bulbool.online resolves in the Cloudflare DNS to a proxied record…
https://cf.sjr.org.uk/tools/check?c73ae44c0f5a4e10b00f782dc7deb6e1#resolvers

Are you trying to delegate nameservers for this domain? There are no NS records for doing so; if you are can you show a screenshot of your DNS records.

You also seem to have created this record…

dig +short api.bulbool.online.bulbool.online
104.21.91.183
172.67.177.209


these are the DNS records for Bulbool.online where api is the ns record for the api.bulbool.online subdomain. For some reason, when recording a subdomain in the DNS, the full domain api.bulbool.online is shortened to “api”

The dashboard doesn’t show the domain name after a subdomain, so that is normal to see. As above, api.bulbool.online is resolving ok. (The same applies for your *, www, dkim._domainkey and _dmarc records).

but as a result, the subdomain does not display the presence of cloudflare anywhere when checking. Tell me what needs to be configured besides NS records

There are no specific NS records for api.bulbool.online as nameservers are not delegated from the nameservers of bulbool.online. The nameservers for bulbool.online (faye.ns.cloudflare.com and pedro.ns.cloudflare.com) return authoritative answers for api.bulbool.online.

In the same way, there are no NS records for www.microsoft.com.

dig +trace +nodnssec -4 api.bulbool.online ns

; <<>> DiG 9.18.24 <<>> +trace +nodnssec -4 api.bulbool.online ns
;; global options: +cmd
.			517129	IN	NS	a.root-servers.net.
.			517129	IN	NS	b.root-servers.net.
.			517129	IN	NS	c.root-servers.net.
.			517129	IN	NS	d.root-servers.net.
.			517129	IN	NS	e.root-servers.net.
.			517129	IN	NS	f.root-servers.net.
.			517129	IN	NS	g.root-servers.net.
.			517129	IN	NS	h.root-servers.net.
.			517129	IN	NS	i.root-servers.net.
.			517129	IN	NS	j.root-servers.net.
.			517129	IN	NS	k.root-servers.net.
.			517129	IN	NS	l.root-servers.net.
.			517129	IN	NS	m.root-servers.net.
;; Received 239 bytes from 1.1.1.1#53(1.1.1.1) in 9 ms

online.			172800	IN	NS	b.nic.online.
online.			172800	IN	NS	a.nic.online.
online.			172800	IN	NS	f.nic.online.
online.			172800	IN	NS	e.nic.online.
;; Received 291 bytes from 198.41.0.4#53(a.root-servers.net) in 13 ms

bulbool.online.		3600	IN	NS	faye.ns.cloudflare.com.
bulbool.online.		3600	IN	NS	pedro.ns.cloudflare.com.
;; Received 103 bytes from 185.24.64.54#53(b.nic.online) in 12 ms

bulbool.online.		1800	IN	SOA	faye.ns.cloudflare.com. dns.cloudflare.com. 2336583988 10000 2400 604800 1800
;; Received 109 bytes from 162.159.44.183#53(pedro.ns.cloudflare.com) in 17 ms

Are you actually trying to delegate nameservers for api.bulbool.online? api.bulbool.online has an A record in your Cloudflare DNS already so I assume not.

We configured cloudflare for the main domain bulbool.online and expected that the subdomain api.bulbool.online would also have cloudflare automatically configured since it is a subdomain for bulbool.online

what needs to be done for cloudflare to also be on the api.bulbool.online subdomain?

api.bulbool.online is proxied in your DNS records so Cloudflare’s features are being applied to this subdomain. What makes you think it is not?

2 Likes

when testing the subdomain api.bulbool.online, cloudflare ns records do not appear anywhere

Your query in the screenshot is not correct. An individual subdomain doesn’t have NS records associated with them unless it has been specifically set to delegate DNS resolution to a nameserver other than the parent.

If you want to determine what nameserver returned the query you would need to use a different tool such as dig and interpret the results. But as @sjr indicates the answer is being served by Cloudflare nameservers and the result is consistent with a proxied host name.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.