DNS record to login to my webmail not propagating

Hi my domain creatinghealth.com.au is with Crazy domains and installed the free ssl here in cloudflare. I have issues logging in to my webmail and this error pops up -

and using this https://rc.ds.network/ to login. The tech support from crazy domain told me to add these records in cloudflare -

Record type: MX record
Host: @ or creatinghealth.com.au
Priority: 1
MX record: mail.creatinghealth.com.au

Record type: A record
Host: mail.creatinghealth.com.au
TTL: default or 14400
IP address: 122.201.127.17

Record type: TXT record
Host: @ or creatinghealth.com.au
TTL: default or 14400
TXT record: v=spf1 +a +mx +ip4: include:_spf.syrahost.com - all

Record type: TXT record
Host: default._domainkey.creatinghealth.com.au
TTL: default or 14400
TXT record: v=DKIM1; k=rsa; p=MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAsG01jas0iBgEt5M7JBUxmtuFuc1puO2/O+1EGKOiSKWIxnZF/sJNzLq4CnVy3rbBvKrHeO+hLg2/CNN7I1EvwmJhhUg6xCG9y2YXD6GWk1LLucioLXhasQmonoADRO1XgVKZAd+G6eu7yBAmk9Xi2Rm/2/p3QfK0WLHfLU4r/aj4wq+EwTC3ALNNnQvs/tB0tzoHPegR4xvIusRiBOGqSIg8prXUWsgvH/ZKQjl0P4cnQnIBcblU866pp233A5DQBTmWLEN5S60SSAAxZnM+GiXwgpYzhCdDJLk83AZUJbSSMz0lkbJLBjn/xn0PU530NI59Dm1bIdK01wNNMa1ORQIDAQAB;

Heres what my dns settings look like:

It’s been more than 24hours and im still unable to log in. Please help.

Why is that statement just always the clear giveaway that one does not have a proper SSL certificate on their server?

No, Cloudflare alone is not enough. You also need a proper certificate on your server and you don’t have that, your site only works on HTTP.

Contact your host and get them to configure your server properly for HTTPS first.

Does this have anything to do with my email?

This is about your overall setup.

The SSL is working fine https://www.creatinghealth.com.au/. Sorry i’m not very tech savvy when it comes to this

As I explained it is not, your server is not secure. You have an insecue encryption mode on Cloudflare right now.

Okay is this why i cant login to my webmail?

Possibly. You really should fix that first.

Okay thanks, I’ll let you know what they say.

Should they want to argue, point them to this output.

$ curl --resolve creatinghealth.com.au:443:122.201.127.17 https://creatinghealth.com.au
curl: (51) SSL: no alternative certificate subject name matches target host name 'creatinghealth.com.au'

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.