DNS Record Propagation time

Hi all

I changed website hosting from WPEngine to Squarespace.

I updated my Cloudflare account to point to the Squarespace DNS by adding and modding the existing DNS records.

Over 24 hours later and Cloudflare still hasn’t started propagating the A, CNAME and TXT changes I made, according to DNS checkers like whatsmydns.net.

How long must I wait?

Why does Cloudflare take so long to initiate this?

Thanks
Daren

Simple rule-of-thumb:

NS propagation: max 48h
DNS propagation (:orange:): immediately
DNS propagation (:grey:): depends on set TTL

So if the DNS Entry was always Proxied (:orange:) it should have happened immediately.
If not: check the TTL

Thanks for the reply M4t1n.

NS haven’t changed.

TTL is set to Auto and Proxied

Just nothing happening.

If you provide a domain I can try to check what is going on.

Thanks man, darencox.com

Directly resolves for me to Squarspace.
Everything is working. Have fun :slight_smile:

What probably went wrong:

  1. your localy used DNS (best is 1.1.1.1 => CloudFlares DNS)
  2. local DNS Cache

To confirm it is working in general please try to call the Domain from your mobilephone via mobile internet (not WiFi).

You can see my website?

I just tried my mobile phone (network not wifi) and still get the squarespace message “this website is pending domain owner verification”

And how come whatsmydns.net still shows the old IP addresses?

Appreciate your help M4rt1n!

If you get a squarspace massage the DNS propagation was successfully :slight_smile:

Yes I see this message aswell:

This is like you mentioned a squarspace massage with a link (“manage your domain settings here.”) follow this link and follow their documentation on how to validate/verify your domain.

But the DNS change to point your Domain to Squarspace was successfully.

Now you have to validate your Domain ownership with 3 things:

  1. CNAME of squarespace._domainkey
  2. TXT @
  3. TXT _dmarc

You have finished step 2 & 3. But for step 1 you made a little mistake. If you CNAME something with :orange: CloudFlare actually will create public A-Entries and not a CNAME. So you have to unproxy (:grey:) your entry:

squarespace._domainkey.darencox.com

Then wait untill its propagated (1 min maybe) and see how you can make SquarSpace recheck for that CNAME.

EDIT:

can see the correct CNAME :+1:

Haaaahhh, i have 2 other CNAMEs from squarespace for www and verify.squarespace.com should I unproxy those too?

Yes, both other CNAMES which you create after this docs:

must be unproxied aswell. Then click according to the documentation on:

click Refresh below the records.

Notice:

It can take 24 to 72 hours for the connection to start working properly.

Dont worry it surely will not take that long.

The Dashboard even should show you what you have set up correct and what is missing:
(should look somewhat like this)

I seeeeeee :smile:

I’ll keep fiddling, thanks VERY much for your time Mart1n, really appreciate it :+1::+1:

Daren

You’re welcome!
Enjoy the CloudFlare community :slight_smile:

1 Like