Dns record problem

hello,
few days ago, I bought a domain on Cloudflare registrar.
I created some NS type DNS records on this domain’s subdomains using the ns servers provided by a hosting provider and everything worked. The problem is that i recently added NS type DNS records on the root of the domain and it’s not changing the NS related to the root.

I created a subdomain to do some tests, set the NS of this subdomain and the root to my hosting provider NS, and used a website call ‘whatsmydns’ to requests the domain/subdomain.
here is the result :
subdomain => redirect using the right NS
domain => redirect using the Cloudflare NS

Is there something i’m missing to change the ns of the domain’s root ?

PS : When i tried an A record on the root, it worked, but with my actual hosting provider, i can’t have a dedicated ip adress.

That will be an issue, you need that A record. I’d look through some of the #tutorial on DNS records for background.

Considering what you said about the necessity of an A record, i used the shared ip additionaly to the NS, and it worked. Thank you Cloonan !

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.