DNS record not updating

Hi, I’ve been using cloudflare for quite a long while already and having a few dozen of domain using cloudflare.

Recently, I’ve added a domain which is :
zerver.co

And I’ve added an A-record but it seems not pointing to the IP address I’ve set.
I’ve also tried adding cname record but it doesn’t work either.

P.S.

  1. I’ve successfully set up the DNS server to cloudflare.
  2. DNSSEC was also pointing correctly to cloudflare.
  3. I’ve tried both using the proxy and without using the proxy provided by cloudflare but both of them doesn’t work.
  4. I used mxtoolbox to check my domain dns record and it shows that I’m not having any DNS record.
  5. My server is working and another domain using cloudflare pointing to that ip works normal.

Are you able to post a full screenshot of the DNS tab of your Cloudflare dashboard (redacting sensitive data like IPs)?

I don’t mind exposing my ip as it’s easy to reverse finding the ip if I’m not proxing my ip.

PS.
The sub-domains are short forms
Etc. atestwop= a record test without proxy

1 Like

For easy access of those records , I’ll type them below so you can just copy them directly:

atestwop.zerver.co
atestwp.zerver.co
ctestwop.zerver.co
ctestwp.zerver.co

1 Like

Sorry for the delay in replying.

Points to 51.68.214.114 from my lookup which appears correct.

Points to 2 Cloudflare IP addresses from my lookup which is expected as the record is proxied (set to :orange:)

Points to ldn00.hkgcity.com. for me

Points to 2 Cloudflare IPs as A records, again expected as they are proxied (:orange:) and therefore the CNAMEs are flattened.

These all seem OK to me and match with your screenshot.

Okay, I’ll check is the problem on my side.

1 Like

I can now successfully see the record pointing to my ip in “mxtoolbox”, but the website is still not showing and ping failed on both of my device. I tried switching networks and DNS servers on my device but it still doesn’t work

Yes I know I’m not pointing to cloudflare, as I’m in a hurry and I have to use the website immediately, I have no choice but to point to other DNS servers to finish the job, maybe I’m dropping this site out of cloudflare temporary and will retry later after I have some time to realize what’s happening to it.

You can’t use any of cloudlfare’s DNS without having your name servers pointed at the ones assigned to you.

I was using cloudflare when i ask this question, but I’m pointing it away from cloudflare for now since the problem is not solving in a short time and I need to use the site in a hurry. It’s a pity for this but i’m using the site in an emergency so i guess pointing it to other dns is my only way.

It sounds like the issue could be with your dns cache. If you ever switch it back to Cloudflare, I would flush your cache.

I tried a couple of device with cloudflare dns, google dns, opendns, but they still got the same result which is unavailable to resolve my domain, even using ssh to connect to a grey cloud

I was thinking about is the problem on the domain side. Since all of my other domains on cloudflare runs good without problem. But it’s weird cause i’ve checked tons of my setting on cloudflare and disabled almost all features for this domain but it still didn’t work. I’ve checked almost everything i know about dns, my cache, blacklist, other dns servers, ttl … bla bla bla… but it just won’t work

How long after the change were you testing it, because it can take sometime for the changes to move over.

I guess at least 8 hours as I do it before I sleep and check after I wake up. I know DNS record updates could be long as 48 hours but it usually takes around 5 minutes for cloudflare to update. I’ve also thought of that reason might because of godaddy’s dns (the domain was registered on godaddy) server was not updated yet. But after I moved everything back to godaddy, I found everything is running quite smooth and fast. So I don’t think it’s the problem of delay

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.