DNS Record not resolve - after 1 year using CF?


#1

Hi,

I use Cloudflare for over a year. Since today I can’t resolve the IP of my domain from any device (or website e.g. mxtoolbox or dnschecker.org).

MXToolbox response this: http://imgur.com/TcKWLKj

http://imgur.com/MyaEDy2

http://imgur.com/ubX6j1C

I haven’t changed anything in Cloudflare. The A-Record for my Domain still exists with my IP-address (and the CF-DNS-Nameservers are entered where I have registered the domain).

Do you have any suggestions?

Best regards


#2

Hello there,

From my looking glasses(HK/UK/JP/SG), your website appears online. I wonder the SOA caused this, as it is just a warning and not blocking DNS resolve. Most of the DNS tools out there consists of presets, which allows them to perform either “marketing” or “promote” themselves a better tool.

Apart from this, your apex domain consists a non-proxied A record, while the ‘www’ domain is proxied. You may want to check out if it is done by mistake.

You may also want to contact support instead of posting here, as there maybe some sensitive information you need to tell support.

Cheers!


#3

Have you tried deleting and recreating NS records in your CF panel?


#4

Hi, thanks for your replies.

I have tried recreating the a-record and now it looks like it’s working again. Do you know if recreating a record creates a new ID for this record (I’m on the road and a static program is updating the IP of this specific record)?

Is this a known error or do you know why/how this error can occur (this shouldn’t happen again)?


#5

If the website is resolvable from external, perhaps try switching your computer’s DNS resolver?


#6

My guess is a broken update or a hard to produce bug in CF had happened to you. I’m not a user of service so don’t know if user will get a new ID or not but for sure internal ID would be a new one. @ryan