DNS record is dropping part of the name

I am trying to set up my subdomain as a DNS record in Cloudflare in order to allow remote access to my Home Assistant instance. When adding the required CNAME record for _acme-challenge.automation.mydomain.com the “.mydomain.com” section is not being saved which (I believe) is stopping me from completing what I want to achieve:

Required by Nabu Casa:

Record Data Entered into Cloudflare DNS:

Saved record in Cloudflare DNS:

Verification from Nabu Casa:
Capture3

I have no idea how to resolve this, and would appreciate some help from one of the more enlightened people here as am relatively new to setting up proxy’s.

Please be patient with me!

That’s correct behavior. Putting the same domain after every subdomain takes up too much space.

The issue is most likely due to your CNAME record being :orange: Proxied. Toggle it to :grey: DNS Only, then it should validate within five minutes or so.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.