DNS Propogation for Website Outside of Cloudfare

Replace (ColoradoTechnology-org with ColoradoTechnology.org) in code.

DNS for ColoradoTechnology-org is hosted on our server outside Cloudfare. We recently received email from customer stating that ColoradoTechnology-org doesn’t resolve when using Cloudfare DNS. Any suggestions to resolve?

Here’s email from client:

Here are 2 failed queries to the Cloudflare servers (1.1.1.1, 1.0.0.1), followed by successful queries to one of Google’s servers (8.8.8.8) and one of OpenDNS’s servers (208.67.222.222).

$ dig @1.1.1.1 ColoradoTechnology-org

; <<>> DiG 9.11.4-P2-RedHat-9.11.4-26.P2.el7_9.5 <<>> @1.1.1.1 ColoradoTechnology-org

; (1 server found)

;; global options: +cmd

;; Got answer:

;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 39803

;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:

; EDNS: version: 0, flags:; udp: 1232

; OPT=15: 00 16 ("…")

;; QUESTION SECTION:

;ColoradoTechnology-org. IN A

;; Query time: 599 msec

;; SERVER: 1.1.1.1#53(1.1.1.1)

;; WHEN: Sun Aug 22 11:30:43 MDT 2021

;; MSG SIZE rcvd: 57

$ dig @1.0.0.1 ColoradoTechnology-org

; <<>> DiG 9.11.4-P2-RedHat-9.11.4-26.P2.el7_9.5 <<>> @1.0.0.1 ColoradoTechnology-org

; (1 server found)

;; global options: +cmd

;; Got answer:

;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 5559

;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:

; EDNS: version: 0, flags:; udp: 1232

; OPT=15: 00 16 ("…")

;; QUESTION SECTION:

;ColoradoTechnology-org. IN A

;; Query time: 577 msec

;; SERVER: 1.0.0.1#53(1.0.0.1)

;; WHEN: Sun Aug 22 11:30:51 MDT 2021

;; MSG SIZE rcvd: 57

$ dig @8.8.8.8 ColoradoTechnology-org

; <<>> DiG 9.11.4-P2-RedHat-9.11.4-26.P2.el7_9.5 <<>> @8.8.8.8 ColoradoTechnology-org

; (1 server found)

;; global options: +cmd

;; Got answer:

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13450

;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:

; EDNS: version: 0, flags:; udp: 512

;; QUESTION SECTION:

;ColoradoTechnology-org. IN A

;; ANSWER SECTION:

ColoradoTechnology-org. 14399 IN A 207.244.77.39

;; Query time: 112 msec

;; SERVER: 8.8.8.8#53(8.8.8.8)

;; WHEN: Sun Aug 22 11:31:00 MDT 2021

;; MSG SIZE rcvd: 67

$ dig @208.67.222.222 ColoradoTechnology-org

; <<>> DiG 9.11.4-P2-RedHat-9.11.4-26.P2.el7_9.5 <<>> @208.67.222.222 ColoradoTechnology-org

; (1 server found)

;; global options: +cmd

;; Got answer:

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 50069

;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:

; EDNS: version: 0, flags:; udp: 4096

;; QUESTION SECTION:

;ColoradoTechnology-org. IN A

;; ANSWER SECTION:

ColoradoTechnology-org. 14400 IN A 207.244.77.39

;; Query time: 72 msec

;; SERVER: 208.67.222.222#53(208.67.222.222)

;; WHEN: Sun Aug 22 12:27:55 MDT 2021

;; MSG SIZE rcvd: 67

I do see that InteractiveWest is authoritative for the domain. Whatever issue is impacting your domain might be specific to Cloudflare.

Name Server: NS3.INTERACTIVEWEST.NET
Name Server: NS4.INTERACTIVEWEST.NET

It resolves for me through 1.1.1.1 LAX. Here are some tips:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.