DNS Propagation Issue after domain expired/renewed (CNAME, A records) - Website down

Hi folks - Can’t seem to determine what has broken in this process and looking for some advice.

I recently had a domain renewal issue that caused my domain to expire and Cloudflare to ultimately purge my DNS records. Long story, but my website was down ~ 2 weeks before we realized the issue.

Upon discovery, I renewed the domain (singularitysci{dot}com) through GoDaddy and setup DNS again through Cloudflare.

My DNS records for email appear to be functioning properly (O365), but I have added CNAME and A records for my website and after roughly 18 hrs I still have no propagation of my records and/or my website is not accessible.

  • List item

I’m hosting through Squarespace and followed Cloudflare’s specific instructions in their Support article.

When I check DNS propagation I get no results for the CNAME or A records.

Here are my DNS records from Cloudflare

I am not able to embed a second screenshot, but Squarespace shows that DNS settings are not found when queried.

Any advice? Did my Domain expiration (it is now renewed) screw me up and I need to wait further?

I imagine it’s trying to check the records match those asked for but while the records are proxied it won’t see that. If you switch them from :orange: to :grey: does it start working?

Your domain resolves for me but gives an error from the host.

1 Like

Based on Cloud Support article (articles/360020991331) it should be working with the verify[dot]squarespace[dot]com record - but it isn’t. Apparently I can’t embed an HTML link in this post

Just flipped them off Proxy to see what the result is, will report back shortly.

Still got nothing, updated settings below

Any other comments or ideas? I am stuck here, this seems to be a Cloudflare issue as Squarespace is not recognizing any of the DNS data and it doesn’t seem to be propagating anywhere when I check common DNS propagation tools.

With the hidden Squarespace verification CNAME, it’s impossible for anyone here to check it for you.

latest screenshot with those areas visible – still not able to get anything working on the website side

Thanks for the updated details.

Your DNSSEC is invalid.

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
; EDE: 9 (DNSKEY Missing): (no SEP matching the DS found for singularitysci.com.)
;; QUESTION SECTION:
;wh6m8htg9bbg4c5c974b.singularitysci.com. IN CNAME

Cloudflare has both a Setup Guide and a Troubleshooting Guide for DNSSEC that should help you get this fixed.

1 Like

Thanks so much! I feel like such an idiot at the moment for not looking at the DNSSEC issue, should know better. Solved it immediately really appreciate it.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.