DNS propagation hasn't happened after 48 hours, urgently need to access site/edit code, can you help?

I recently upgraded my hosting to a private VPS and after updating the DNS records with the new IP, the site has not propagated. It’s 48 hours later and we can’t edit/test any code.

I’m sure I’ve done everything I’m meant to, my host support team walked me through, but clearly something has gone wrong/there’s been a mistake.

Can anyone please help? We have a tight deadline and every day lost is eating into crucial time :frowning:

Thanks!

May I ask what is your domain name?
And the DNS records are proxied (:orange: cloud) too?

Also, the Website is not loading as you only changed the IP for the A record at Cloudflare DNS tab, or it’s actually due to the nameserver change for your domain?

How about the SSL? Before moving to Cloudflare, was your Website working over HTTPS connection?

Firewall maybe?

Furthermore, kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

Hello. Am in a bit of an urgent situation. Updated my DNS with new IP address and after 48 hours nothing has changed. Really need the site to propagate ASAP as have teams waiting to finish bugs and testing. My host support team walked me through exactly what I needed to change, and I did it right. My developer has checked, says it’s right.

Trying to get through to CF support team, not having any luck.

Pretty grumpy as I upgraded today, tried three times. First two times (6 and 4 hours ago) there was an issue and I emailed billing to raise a ticket and never heard back. Finally billing worked, and now I’ve got an automated email asking me to post here. I am confused as I thought support at CloudFlare was good.

We have a hard launch date (due to my lead developer getting married!) and every day missed is eating away at crucial time.

Anyway - please help! Let me know what info you need. Thank you SO SO much in advance.

You have not provided the domain name in question, so it is difficult to help. Can you provide the domain name, and steps to reproduce the issue?

How are you testing propagation?

Is the hostname proxied or DNS only (:orange: or :grey:.

FYI, Using the MoreHelp tag after 60 seconds will be more likely to have your posts ignored/muted than responded to.

1 Like

Thanks for answering so soon Michael. I’m new here so not sure how the forum works/what moderators/contributors have access to :slight_smile: noted on the morehelp! Won’t do that again.

www.heynibble.com, but the site is behind a password.

We know the site isn’t propagated because we edited some copy on one of the main pages to say ‘NEW SITE’ so that we’d know when it was complete. We had made some changes to the code using host file modification before we updated the DNS, so the site showing is an old version and we can tell due to the ‘NEW SITE’ copy being missing and other bugs we’ve since updated.

By hostname, in the DNS records, do you mean the MX record that says ‘heynibble’? If so it is DNS only.

Blockquote

Re steps to reproduce the issue, I can tell you that I changed all A Records apart from local host to the new IP, and then updated any records with an old server URL with a new one. My host support talked me through, but maybe they made a mistake or I did it wrong?

I see the Cloudflare IP behind, meaning you are using :orange: (proxied), furthermore it’s asking me for 401 Auth too.

Does it mean you have modified your hosts file on your device (PC) and pointed the domain to the new IP there? (would have to remove them and flush your local ISP DNS cache - or restart router at least)

Just to make sure and get the right answer, at the Cloudflare DNS tab or somewhere else?

May I ask have you tried clearing your Web browser cache and/or purging cache at Cloudflare?

I see your domain nameservers are pointed to Cloudflare - which is correct.

Thank you. Answering below:

  1. Yes everything is proxied with orange clouds. heynibble.com
  2. I haven’t changed nameservers, am I meant to? My host (In Motion) didn’t say to do that. They said they couldn’t update the IP/DNS as they don’t host the name servers, CloudFlare does
  3. SSL was set up before migration and working fine with https
  4. I’ll check this
  1. Yes it is behind password as we are pre-launch
  2. I have not modified anything on my laptop, I wonder if actually my devs weren’t able to modify the host file on their device (Ive messaged to confirm but he’s offline). How can I check that the site is propagated, is there a way to know for sure?
  3. Yes exactly
  4. Have tried using incognito, but now I’m wondering if it is propagated and our test for checking just didn’t happen/work…

@lizzieearl is this working as you expect now? Propagation of the nameservers takes some time and you can check progress here, DNS Checker - DNS Propagation Check & DNS Lookup.

WRT

Your developer can see the files for your site that they have placed on your origin server. This is a copy process to the server and does not take time to propagate. The developer should be able to demo the site for you to answer any questions you may have.

Sorry for the delay, I’m back to close the loop :slight_smile: Thank you so so much for your help. It turned out that for some reason propagation just took many days. Was expecting it to be 24 hours max. Glad it’s nothing more complex.

Thank you again!!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.