DNS propagation error

Hello, I migrated for a client his information website from NationBuilder to OVH and every time I add it to Cloudflare, after an hour it points to a NationBuilder page “Page cannot be found. The URL you requested either moved or no longer exists”. At first I thought it was due to the DNS propagation delay but no because more than a month after the migration, the error persists. I tried 5 times changing security settings and DNS but to no avail… All my other sites on your platform are working perfectly Please let me know how to add the site to Cloudflare. Thanks in advance.

What’s the site?

1 Like

The site URL les2rives.info
Thank you neiljay ! I think some US DNS servers still points to NationBuilder months after the migration.

I have no issues entering to your site:

Have you tried’s and’s DNS cache purging features? — the Internet’s Fastest, Privacy-First DNS Resolver
Flush Cache - Google Public DNS

Hope it helps!

1 Like

Thanks a lot ! In fact the site is functional and I forgot to mention that the site is in production and that every time I add it to Cloudflare (only at night) and I have the error, I immediately reset the DNS from OVH and I delete the site from Cloudflare… Note that before the migration the site existed for 2 years with a lot of traffic at NationBuilder. I’ll try again tonight and let you know.

If you only wind up a sending traffic to NationBuilder when :orange: proxied, I would suspect NationBuilder uses Cloudflare For SaaS and never removed your domain name from their account. If your site works with Cloudflare set to :grey: DNS only, I’d look into the following #tutorial.

The Liberate The Hostname tool has much success in freeing captive churned hostnames.


I suspected the same thing and your analysis is excellent, epic network! There are no other possible explanations. Thank you very much for your input. I will read the tutorial and try with this tool. I will keep you informed.

1 Like

Hello, unfortunately it didn’t work! I was able to release the domain but not the www subdomain.
I tried anyway to add the site to Cloudflare but as soon as the DNS changed I had the error page attached.
A clarification: the content of the website was on NationBuilder and the domain at the registrar GoDaddy which also uses Cloudflare. Tomorrow I try to contact them.
Having a free account, I cannot contact Cloudflare for the resolution of the problem! I’m sure they have the solution.
Another lead? Thanks in advance

1 Like

May I just ask if you have tried for both non-www and with www using the above tool to “Liberate hostname”, or only non-www which as it seems what you say, worked? :thinking:


Yes fritex, it worked very well with the no www. After performing the 3 steps, I noticed a “pending” and after a “liberated” at the bottom of the tool for verification. On the other hand for the www it remained on pending! I just checked, still the same (capture attached)… My client is an oldshcool journalist and he wants to keep his domain with the www.
non www capture

www capture