DNS Problems when switch name servers

  • The domain is hosted on Hostinger with IP address 156.67.69.78. The site itself is working when checking with SkipDNS. However, when we change domain’s nameserver to Cloudflare we are getting 404 not found everywhere

  • We have already tried purging cache everywhere and enabling development mode

  • Only way we can access site is when using SkipDNS and removing Cloudflare

Hello there,

Would you check this article for the resolution of the same?

https://support.cloudflare.com/hc/en-us/articles/115003014512-4xx-Client-Error#code_404

And that’s with HTTPS when you’re not using Cloudflare?

Thanks for your reply. I was talking with support hostinger for almost 6 hours and not resolve the problem

Yes the site appeared online when we use SkypDNS, HTTPS. But without that tool still show 404 Error

@user10410

Did you read the article for the resolution?

It appears to be the broken link or misconfiguration. What steps have you taken? Would you share the site here?

Yes, the site is https://worldsacross.com/ the proxys are off for now

The steps followed: ( Cloudflare config )
1- Change the name servers to point Cloudflare
2- Proxied the A, AAAA, CNAME records.

Then i chat with hostinger support to resolve the problem. Yesterday we clear the cache, enable the development mode and nothing happens. We wait 24h to DNS propagates well and we turn on the cloudflares proxys.

From that moment the site entered Error 404. And speaking with support, the pointing towards Cloudflare is complete. The only weird thing is that the CNAME record was not propagated

I see you are using wordpress which is in build mode. At the moment, your domain is pointed to Cloudflare but not proxied :orange: Would you do that? Before that, you can ensure on your wordpress settings, its running on https and not on http. Another possible error occurs due to when installing on http. It needs to be https to avoid such error.

Thanks for answer neiljay, yes i use wordpress. In hosting is activated, Force HTTPS - Redirect all website requests over HTTPS. So i dont know what im doing wrong.

It could have been this way: Force https or other settings do it from Cloudflare rather than in hostinger which is why its clashing your site.

Yes, the configuration of https is in hostinger. I turned on the proxy again.

If your site works when not proxied, then it’s probably this:

Hi, i’ve tried this solution but dont pass the status to do that. I migrate my domain to my actual hosting provider. I create a staging from my website and i added dns to Cloudflare and active proxys to that staging. Its works correctly. (https://dev.worldsacross.com/) What can i do in my primary domain to get Cloudflare services?

At the moment, your primary domain is using Cloudflare. You can add CNAME record for www

It’s really frustrating not being able to set up my domain. I have done the steps to release my hostname and start a new configuration to test the service. If I buy a plan, how do I know that the problem will be solved?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.